Bug 1331707 - Some issues with "--show-domain-creator"
Summary: Some issues with "--show-domain-creator"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-29 10:51 UTC by XiaoyunHu
Modified: 2016-11-04 02:02 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.4.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:02:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2269 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2016-11-03 13:34:19 UTC

Description XiaoyunHu 2016-04-29 10:51:14 UTC
Description of problem:
Some issues with "--show-domain-creator"

Version-Release number of selected component (if applicable):
virt-manager-1.3.2-1.el7.noarch


How reproducible:
100%

Steps to Reproduce:
1.There are two connections in virt-manager and both set autoconnect.
2.Run the command "virt-manager --show-domain-creator -c qemu:///system"

Actual results:
1.The Virtual Machine Manager dialog pop up and the vms of the connection"qemu:///system" are not listed.
2.Both of the connections have connected.

Expected results:
--show-DIALOG-WINDOW
  Display the corresponding "DIALOG-WINDOW" when launching"virt-manager". This function implies --no-conn-autostart and the manager window will not be shown at startup in this case.
  The following "DIALOG-WINDOW" options are currently available:
    --show-domain-creator
      Display the wizard for creating new virtual machines

1.The Virtual Machine Manager dialog pop up and the vms of the connection "qemu:///system" are listed here.
2.As the man page shown, " This function implies --no-conn-autostart and the manager window will not be shown at startup in this case", only the connection qemu:///system should be connected.
3.As "This function implies --no-conn-autostart and the manager window will not be shown at startup in this case" in the man page and bug 1069060 shown, it's better to add some specification for "--show-domain-creator" in man page because of the appearance of Virtual Machine Manager dialog.


Additional info:

Comment 1 Pavel Hrdina 2016-05-20 16:10:10 UTC
Upstream commit:

commit bf99c0ce82e306284b3640f86ea484e5fd55bb02
Author: Pavel Hrdina <phrdina>
Date:   Fri May 20 15:27:17 2016 +0200

    virt-manager: fix --show-domain-creator to not depend on manager window
    
    Commit a0c2fdf4 fixed a bug that there was no way how to close the app.
    
    The original issue isn't present anymore but reverting that commit isn't
    enough.  We need to increment/decrement window count while
    showing/closing the create window in order to not exit right after
    the create window is opened.

Comment 3 XiaoyunHu 2016-06-23 03:19:14 UTC
I can reproduce this bug with package:
virt-manager-1.3.2-1.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch

Steps:
1.There are two connections in virt-manager and both set autoconnect.
2.Run the command "virt-manager --show-domain-creator -c qemu:///system"
3.Click "cancel" button to close the wizard and run "ps -ef|grep virt-manager".
4.Lauch virt-manager.
#virt-manager

Results:
After step2, Display the wizard for creating new virtual machines and the manager window will not be shown as the manpage shown.
After step3, the wizard windows disappear and virt-manager quit successfully.
#ps -ef|grep virt-manager
root 6644 4160 0 10:15 pts/1 00:00:00 grep --color=auto virt-manager
After step4, virt-manager launched successfully.

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.

Comment 6 errata-xmlrpc 2016-11-04 02:02:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html


Note You need to log in before you can comment on or make changes to this bug.