Bug 1331941 - rpc: fix gf_process_reserved_ports
Summary: rpc: fix gf_process_reserved_ports
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: 3.7.11
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On: 1261927
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-30 09:39 UTC by Prasanna Kumar Kalever
Modified: 2016-06-28 12:16 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1261927
Environment:
Last Closed: 2016-06-28 12:16:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-04-30 09:39:40 UTC
+++ This bug was initially created as a clone of Bug #1261927 +++

Description of problem:

Use this bug to file changes that affect source files under rpc/ directory. Real bugs (problem reports, crashes) should have their own bugzilla entry for related patches.

Acceptable changes include:
    -Improve code readability
    -Remove dead code
    -Better error reporting
    - . . .

--- Additional comment from Vijay Bellur on 2015-09-10 08:56:23 EDT ---

REVIEW: http://review.gluster.org/12153 (rpc: Remove unused function) posted (#1) for review on master by Anoop C S (anoopcs@redhat.com)

--- Additional comment from Mike McCune on 2016-03-28 18:22:31 EDT ---

This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

--- Additional comment from Vijay Bellur on 2016-04-14 11:53:17 EDT ---

REVIEW: http://review.gluster.org/13997 (rpc: modify gf_process_reserved_ports to return void) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 1 Vijay Bellur 2016-04-30 09:41:03 UTC
REVIEW: http://review.gluster.org/14128 (rpc: fix gf_process_reserved_ports) posted (#3) for review on release-3.7 by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Vijay Bellur 2016-05-02 11:36:45 UTC
REVIEW: http://review.gluster.org/14128 (rpc: fix gf_process_reserved_ports) posted (#4) for review on release-3.7 by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Vijay Bellur 2016-05-02 17:45:38 UTC
COMMIT: http://review.gluster.org/14128 committed in release-3.7 by Jeff Darcy (jdarcy@redhat.com) 
------
commit a85e75a111941c50ba1996d70328fe686a34ba07
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Sat Apr 30 14:37:40 2016 +0530

    rpc: fix gf_process_reserved_ports
    
    this patch also does minor code cleanups.
    
    Backport of:
    > Change-Id: I0d005bd0f9baaaae498aa1df4faa6fcb65fa7a6e
    > BUG: 1198849
    > Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    > Reviewed-on: http://review.gluster.org/13997
    > Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    
    Change-Id: Ia53ba724f6d31cb2fc609786e31a1b676f55fe01
    BUG: 1331941
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/14128
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Kaushal 2016-06-28 12:16:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.