Bug 1331969 - Ganesha+Tiering: Continuous "0-glfs_h_poll_cache_invalidation: invalid argument" messages getting logged in ganesha-gfapi logs.
Summary: Ganesha+Tiering: Continuous "0-glfs_h_poll_cache_invalidation: invalid argume...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1323424 1332433 1347590
TreeView+ depends on / blocked
 
Reported: 2016-04-30 16:41 UTC by Soumya Koduri
Modified: 2017-03-27 18:26 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1323424
: 1332433 1347590 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:26:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-30 16:42:35 UTC
REVIEW: http://review.gluster.org/14132 (gfapi/upcall: Ignore handle create failures) posted (#2) for review on master by soumya k (skoduri@redhat.com)

Comment 2 Vijay Bellur 2016-05-02 08:18:32 UTC
REVIEW: http://review.gluster.org/14132 (gfapi/upcall: Ignore handle create failures) posted (#3) for review on master by soumya k (skoduri@redhat.com)

Comment 3 Vijay Bellur 2016-05-02 10:12:12 UTC
REVIEW: http://review.gluster.org/14132 (gfapi/upcall: Ignore handle create failures) posted (#4) for review on master by soumya k (skoduri@redhat.com)

Comment 4 Vijay Bellur 2016-05-02 18:14:01 UTC
COMMIT: http://review.gluster.org/14132 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit fb77938fc7810dc5ac16b0de9694157cde93635e
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Sat Apr 30 22:01:47 2016 +0530

    gfapi/upcall: Ignore handle create failures
    
    In "glfs_h_poll_cache_invalidation", we need to send upcall only if there
    is a corresponding inode entry in the gfapi inode table for that handle.
    
    That's because the application will have reference to the inode as long as
    it operates on any handle. That means the only case in which we cannot find
    inode is when the application has closed the handle (either as part of unlink
    or for any other purpose). But since it will have no more references and will
    not be interested in any upcall event for that handle, we can safely ignore such
    cases.
    
    Note: This will affect only that particular applicaiton process/local libgfapi
    client.
    
    Change-Id: I9499cd9c284350d4a271e58f2a0966db65a7a61c
    BUG: 1331969
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/14132
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:26:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.