Bug 1331983 - linker errors in boost (built with gcc-6.0.0) when building with gcc-6.1.1
Summary: linker errors in boost (built with gcc-6.0.0) when building with gcc-6.1.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: boost
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Jonathan Wakely
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1336358 (view as bug list)
Depends On:
Blocks: 1331984
TreeView+ depends on / blocked
 
Reported: 2016-05-01 00:14 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2016-07-05 23:18 UTC (History)
13 users (show)

Fixed In Version: boost-1.60.0-6.fc25 boost-1.60.0-5.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-23 20:04:20 UTC
Type: Bug


Attachments (Terms of Use)
build-of-csdiff-against-boost-1.60.0-5.fc25.txt.gz (4.32 KB, application/x-gzip)
2016-05-04 16:31 UTC, Kamil Dudka
no flags Details
build-of-csdiff-against-boost-1.60.0-6.fc25.txt.gz (9.49 KB, application/x-gzip)
2016-05-04 16:32 UTC, Kamil Dudka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1333355 0 unspecified CLOSED mongodb fails to link: symbol lookup error: mongod: undefined symbol: _ZNK5boost16re_detail_10600031cpp_regex_traits_imp... 2021-02-22 00:41:40 UTC

Internal Links: 1333355

Description Dominik 'Rathann' Mierzejewski 2016-05-01 00:14:33 UTC
Description of problem:
I'm getting linker errors when building latest mkvtoolnix (i.e. the one in git master). According to koschei, they started when gcc was updated from 6.0 to 6.1 in rawhide:
https://apps.fedoraproject.org/koschei/package/mkvtoolnix

Version-Release number of selected component (if applicable):
1.60.0-5.fc25

How reproducible:
Always.

Steps to Reproduce:
1. koji build --nowait --scratch f25 --arch=x86_64 git://pkgs.fedoraproject.org/rpms/mkvtoolnix?#6713cdda7da7c6358564584c825b7d6aa9850c15

Actual results:
[...]
src/common/libmtxcommon.a(codec.o): In function `boost::cpp_regex_traits<char>::transform_primary[abi:cxx11](char const*, char const*) const':
/usr/include/boost/regex/v4/cpp_regex_traits.hpp:966: undefined reference to `boost::re_detail_106000::cpp_regex_traits_implementation<char>::transform_primary[abi:cxx11](char const*, char const*) const'
src/common/libmtxcommon.a(codec.o): In function `boost::cpp_regex_traits<char>::transform[abi:cxx11](char const*, char const*) const':
/usr/include/boost/regex/v4/cpp_regex_traits.hpp:962: undefined reference to `boost::re_detail_106000::cpp_regex_traits_implementation<char>::transform[abi:cxx11](char const*, char const*) const'
collect2: error: ld returned 1 exit status
src/merge/mkvmerge.o: In function `boost::cpp_regex_traits<char>::transform_primary[abi:cxx11](char const*, char const*) const':
/usr/include/boost/regex/v4/cpp_regex_traits.hpp:966: undefined reference to `boost::re_detail_106000::cpp_regex_traits_implementation<char>::transform_primary[abi:cxx11](char const*, char const*) const'
src/merge/mkvmerge.o: In function `boost::cpp_regex_traits<char>::transform[abi:cxx11](char const*, char const*) const':
/usr/include/boost/regex/v4/cpp_regex_traits.hpp:962: undefined reference to `boost::re_detail_106000::cpp_regex_traits_implementation<char>::transform[abi:cxx11](char const*, char const*) const'
collect2: error: ld returned 1 exit status
[...]

Expected results:
Successful linking and build.

Additional info:
I did a new scratch build of current boost (http://koji.fedoraproject.org/koji/taskinfo?taskID=13872567) and used that to build mkvtoolnix and it works, so a simple rebuild is all that's needed.

Comment 1 Richard Shaw 2016-05-03 03:16:11 UTC
This also affect OpenImageIO, any chance the rebuild will be completed soon?

Comment 2 Jonathan Wakely 2016-05-03 09:15:53 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #0)
> Description of problem:
> I'm getting linker errors when building latest mkvtoolnix (i.e. the one in
> git master). According to koschei, they started when gcc was updated from
> 6.0 to 6.1 in rawhide:

I don't understand why that makes any difference, but I've started a new build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=13901061

Comment 3 Richard Shaw 2016-05-03 13:08:40 UTC
Still waiting on the ARM build but that seems to have fixed the problem. Thanks.

Comment 4 Petr Pisar 2016-05-04 12:54:58 UTC
mongodb from mongodb-server-3.2.4-1.fc25 fails to link at run-time against boost-1.60.0-6.fc25:

+ mongod --fork --logpath /builddir/build/BUILD/MongoDB-v1.2.3/mongod.log --pidfilepath /builddir/build/BUILD/MongoDB-v1.2.3/mongod.pid --dbpath /builddir/build/BUILD/MongoDB-v1.2.3/test_db/ --smallfiles
mongod: symbol lookup error: mongod: undefined symbol: _ZNK5boost16re_detail_10600031cpp_regex_traits_implementationIcE17transform_primaryEPKcS4_

Koschei reports it since upgrading boost to 1.60.0-6.fc25 <https://apps.fedoraproject.org/koschei/package/perl-MongoDB>, but I can reproduce it even with 1.60.0-5.fc25 in my virtual machine. That's strange.

Comment 5 Dominik 'Rathann' Mierzejewski 2016-05-04 12:59:04 UTC
Try rebuilding mongodb with the current gcc-6.1.1-1.fc25 and see if it helps. My gut feeling is that it's related to gcc, not boost.

Comment 6 Kamil Dudka 2016-05-04 16:27:47 UTC
I encountered similar linker errors while building the csdiff package.  Building against boost-1.60.0-6.fc25 fixes the problem.

Comment 7 Kamil Dudka 2016-05-04 16:31:35 UTC
Created attachment 1153933 [details]
build-of-csdiff-against-boost-1.60.0-5.fc25.txt.gz

Comment 8 Kamil Dudka 2016-05-04 16:32:04 UTC
Created attachment 1153934 [details]
build-of-csdiff-against-boost-1.60.0-6.fc25.txt.gz

Comment 9 Petr Pisar 2016-05-05 11:22:38 UTC
Indeed rebuilding mongodb against boost-1.60.0-6.fc25 and gcc 6.1.1-1.fc25 helps.

Comment 10 Jonathan Wakely 2016-05-05 18:43:15 UTC
The differences between the boost libs when compiled with gcc-6.0.0 and gcc-6.1.1 are due to https://gcc.gnu.org/r234790 which fixed a bug where an abi-tag didn't propagate to function templates correctly.

Comment 11 Christian Dersch 2016-05-16 00:07:36 UTC
As gcc 6.1.1 has been pushed to 24 now, I get the same issue there. So boost needs a rebuild there too?

Comment 12 Jonathan Wakely 2016-05-16 10:56:56 UTC
(In reply to Christian Dersch from comment #11)
> As gcc 6.1.1 has been pushed to 24 now, I get the same issue there. So boost
> needs a rebuild there too?

Yes, and all the packages that depend on the changed symbols, which I'm in the process of finding. Once I've done that I'll rebuild boost and the affected packages.

Comment 13 Jonathan Wakely 2016-05-19 16:09:41 UTC
Most of the rawhide rebuilds are done. I'm rebuilding Boost for F24 now and will rebuild the affected F24 packages for F24.

Comment 14 Fedora Update System 2016-05-20 17:11:09 UTC
Field3D-1.7.1-2.fc24 OpenImageIO-1.6.12-3.fc24 aqsis-1.8.2-23.fc24 boost-1.60.0-5.fc24 csdiff-1.3.0-1.fc24 dssp-2.2.1-10.fc24 glmark2-2014.03-6.fc24 libcutl-1.10.0-4.fc24 sevmgr-1.00.2-9.fc24 source-highlight-3.1.8-8.fc24 stdair-1.00.2-8.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ce03854337

Comment 15 Fedora Update System 2016-05-20 17:11:28 UTC
Field3D-1.7.1-2.fc24 OpenImageIO-1.6.12-3.fc24 aqsis-1.8.2-23.fc24 boost-1.60.0-5.fc24 csdiff-1.3.0-1.fc24 dssp-2.2.1-10.fc24 glmark2-2014.03-6.fc24 libcutl-1.10.0-4.fc24 sevmgr-1.00.2-9.fc24 source-highlight-3.1.8-8.fc24 stdair-1.00.2-8.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ce03854337

Comment 16 Fedora Update System 2016-05-21 00:42:05 UTC
Field3D-1.7.1-2.fc24 OpenImageIO-1.6.12-3.fc24 adobe-source-libraries-1.0.43-32.fc24 airinv-1.00.1-10.fc24 aqsis-1.8.2-23.fc24 asc-2.6.1.0-4.fc24 boost-1.60.0-5.fc24 cclive-0.9.3-14.fc24 csdiff-1.3.0-1.fc24 cvc4-1.4-11.fc24 davix-0.6.3-2.fc24 dssp-2.2.1-10.fc24 ember-0.7.2-15.fc24 flamerobin-0.9.3-16.20130401snap.fc24 freecad-0.16-2.fc24 fts-3.4.3-3.fc24 glmark2-2014.03-6.fc24 libcutl-1.10.0-4.fc24 libkolabxml-1.0.3-8.fc24 liblas-1.8.0-13.fc24 liblsl-1.11.0-3.fc24 libndn-cxx-0.4.1-2.fc24 libpwiz-3.0.9393-2.fc24 librime-1.2-10.fc24 lucene++-3.0.7-9.fc24 lyx-2.1.4-8.fc24 mapnik-3.0.10-3.fc24 mongo-cxx-driver-1.1.0-4.fc24 ncmpcpp-0.7.3-4.fc24 ompl-1.0.0-11.fc24 openscad-2015.03.2-7.fc24 orthanc-1.0.0-3.fc24 plee-the-bear-0.7.0-5.fc24 pokerth-1.1.1-16.fc24 povray-3.7-0.16.20131116git39ce8a2.fc24 psi4-0.3-7.1881450git.fc24 rcsslogplayer-15.1.1-13.fc24 rcssmonitor-15.1.1-15.fc24 sevmgr-1.00.2-9.fc24 simspark-0.2.4-21.fc24 snapper-0.2.8-4.fc24 source-highlight-3.1.8-8.fc24 spring-100.0-5.fc24 stdair-1.00.2-8.fc24 swift-3.0-0.7.rc2.fc24 sympol-0.1.8-28.fc24 votca-csg-1.3-4.fc24 wesnoth-1.12.5-4.fc24 wt-3.3.5-0.6.rc2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ce03854337

Comment 17 Jonathan Wakely 2016-05-21 00:47:36 UTC
Sorry for the repeated comments about the update, Bodhi isn't very good at handling large updates with many builds, and I had to keep editing the update.

Most of the F24 rebuilds are done. There are a few packages remaining which still need to be rebuilt (in F24 only, not in rawhide):

dmlite
eclib
gazebo
gqrx
grive2
mkvtoolnix
mongodb
pcl
pdns
qpid-cpp
uhd

There are some other packages like mrpt which haven't been rebuilt for rawhide or F24, because they FTBFS in both.

Comment 18 Jonathan Wakely 2016-05-21 00:51:34 UTC
Oh, and openms is still building for F24, but the ARM build takes **forever** and I got sick of waiting for it.

Comment 19 Dominik 'Rathann' Mierzejewski 2016-05-21 10:26:57 UTC
Rebuilding mkvtoolnix now. Please add it to the update if I don't do it within an hour or two of completion.

Comment 20 Jonathan Wakely 2016-05-21 12:26:15 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #19)
> Rebuilding mkvtoolnix now. Please add it to the update if I don't do it
> within an hour or two of completion.

Thanks, I've added it to the update.

Comment 21 Christian Dersch 2016-05-21 13:18:11 UTC
I also rebuilt my boost-dependent packages, please add them to the update: grive2-0.5.0-4.20160114gitae06ecc.fc24 and libASL-0.1.6-5.fc24

Thank you :)

Comment 22 Jonathan Wakely 2016-05-21 14:19:58 UTC
Done - thanks!

Comment 23 Fedora Update System 2016-05-22 03:56:29 UTC
Field3D-1.7.1-2.fc24, OpenImageIO-1.6.12-3.fc24, adobe-source-libraries-1.0.43-32.fc24, airinv-1.00.1-10.fc24, aqsis-1.8.2-23.fc24, asc-2.6.1.0-4.fc24, boost-1.60.0-5.fc24, cclive-0.9.3-14.fc24, csdiff-1.3.0-1.fc24, cvc4-1.4-11.fc24, davix-0.6.3-2.fc24, diet-2.9-8.fc24, dssp-2.2.1-10.fc24, ember-0.7.2-15.fc24, flamerobin-0.9.3-16.20130401snap.fc24, freecad-0.16-2.fc24, fts-3.4.3-3.fc24, glmark2-2014.03-6.fc24, grive2-0.5.0-4.20160114gitae06ecc.fc24, libASL-0.1.6-5.fc24, libcutl-1.10.0-4.fc24, libkolabxml-1.0.3-8.fc24, liblas-1.8.0-13.fc24, liblsl-1.11.0-3.fc24, libndn-cxx-0.4.1-2.fc24, libpwiz-3.0.9393-2.fc24, librime-1.2-10.fc24, lucene++-3.0.7-9.fc24, lyx-2.1.4-8.fc24, mapnik-3.0.10-3.fc24, mkvtoolnix-9.1.0-1.fc24.1, mongo-cxx-driver-1.1.0-4.fc24, ncmpcpp-0.7.3-4.fc24, ompl-1.0.0-11.fc24, openms-2.0.0-33.20160121git6f51b3.fc24, openscad-2015.03.2-7.fc24, orthanc-1.0.0-3.fc24, plee-the-bear-0.7.0-5.fc24, pokerth-1.1.1-16.fc24, povray-3.7-0.16.20131116git39ce8a2.fc24, psi4-0.3-7.1881450git.fc24, rcsslogplayer-15.1.1-13.fc24, rcssmonitor-15.1.1-15.fc24, sevmgr-1.00.2-9.fc24, simspark-0.2.4-21.fc24, snapper-0.2.8-4.fc24, source-highlight-3.1.8-8.fc24, spring-100.0-5.fc24, stdair-1.00.2-8.fc24, swift-3.0-0.7.rc2.fc24, sympol-0.1.8-28.fc24, votca-csg-1.3-4.fc24, wesnoth-1.12.5-4.fc24, wt-3.3.5-0.6.rc2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ce03854337

Comment 24 Fedora Update System 2016-05-23 20:03:59 UTC
Field3D-1.7.1-2.fc24, OpenImageIO-1.6.12-3.fc24, adobe-source-libraries-1.0.43-32.fc24, airinv-1.00.1-10.fc24, aqsis-1.8.2-23.fc24, asc-2.6.1.0-4.fc24, boost-1.60.0-5.fc24, cclive-0.9.3-14.fc24, csdiff-1.3.0-1.fc24, cvc4-1.4-11.fc24, davix-0.6.3-2.fc24, diet-2.9-8.fc24, dssp-2.2.1-10.fc24, ember-0.7.2-15.fc24, flamerobin-0.9.3-16.20130401snap.fc24, freecad-0.16-2.fc24, fts-3.4.3-3.fc24, glmark2-2014.03-6.fc24, grive2-0.5.0-4.20160114gitae06ecc.fc24, libASL-0.1.6-5.fc24, libcutl-1.10.0-4.fc24, libkolabxml-1.0.3-8.fc24, liblas-1.8.0-13.fc24, liblsl-1.11.0-3.fc24, libndn-cxx-0.4.1-2.fc24, libpwiz-3.0.9393-2.fc24, librime-1.2-10.fc24, lucene++-3.0.7-9.fc24, lyx-2.1.4-8.fc24, mapnik-3.0.10-3.fc24, mkvtoolnix-9.1.0-1.fc24.1, mongo-cxx-driver-1.1.0-4.fc24, ncmpcpp-0.7.3-4.fc24, ompl-1.0.0-11.fc24, openms-2.0.0-33.20160121git6f51b3.fc24, openscad-2015.03.2-7.fc24, orthanc-1.0.0-3.fc24, plee-the-bear-0.7.0-5.fc24, pokerth-1.1.1-16.fc24, povray-3.7-0.16.20131116git39ce8a2.fc24, psi4-0.3-7.1881450git.fc24, rcsslogplayer-15.1.1-13.fc24, rcssmonitor-15.1.1-15.fc24, sevmgr-1.00.2-9.fc24, simspark-0.2.4-21.fc24, snapper-0.2.8-4.fc24, source-highlight-3.1.8-8.fc24, spring-100.0-5.fc24, stdair-1.00.2-8.fc24, swift-3.0-0.7.rc2.fc24, sympol-0.1.8-28.fc24, votca-csg-1.3-4.fc24, wesnoth-1.12.5-4.fc24, wt-3.3.5-0.6.rc2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Dr. David Alan Gilbert 2016-05-23 20:36:37 UTC
Hmm, is there a uhd rebuild? (gqrx worked for me with a rebuild of uhd).

Comment 26 Jonathan Wakely 2016-05-24 07:31:25 UTC
(In reply to rh from comment #25)
> Hmm, is there a uhd rebuild? (gqrx worked for me with a rebuild of uhd).

As I said in comment 17, a few packages still need to be rebuilt.

Comment 27 Jonathan Wakely 2016-05-24 12:27:13 UTC
uhd fails to build on arm, see Bug 1308204

Comment 28 Adrian Reber 2016-05-25 14:11:44 UTC
*** Bug 1336358 has been marked as a duplicate of this bug. ***

Comment 29 Rich Mattes 2016-07-05 23:18:36 UTC
(In reply to Jonathan Wakely from comment #17)
> Sorry for the repeated comments about the update, Bodhi isn't very good at
> handling large updates with many builds, and I had to keep editing the
> update.
> 
> Most of the F24 rebuilds are done. There are a few packages remaining which
> still need to be rebuilt (in F24 only, not in rawhide):
> 
> dmlite
> eclib
> gazebo
> gqrx
> grive2
> mkvtoolnix
> mongodb
> pcl
> pdns
> qpid-cpp
> uhd
> 
> There are some other packages like mrpt which haven't been rebuilt for
> rawhide or F24, because they FTBFS in both.

I just found this error in sdformat and gazebo.  I'm fixing it now, but a head's up before f24 went out would have been appreciated.  I don't see the error in pcl (ldd -r /usr/lib64/libpcl_*.so |grep undefined doesn't return any results)  And it looks like I just happened to fix mrpt 2 days after the updated gcc/boost went stable, so no problem there either.


Note You need to log in before you can comment on or make changes to this bug.