Bug 133199 - incremental compiler tries to process recursive jsp's
Summary: incremental compiler tries to process recursive jsp's
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: Lomboz   
(Show other bugs)
Version: 2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Handcock
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
: 133198 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-22 13:29 UTC by Jeff Pound
Modified: 2016-05-26 11:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 11:41:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
java core (562.02 KB, text/plain)
2004-09-22 13:30 UTC, Jeff Pound
no flags Details

Description Jeff Pound 2004-09-22 13:29:17 UTC
Description of problem:
If a jsp includes itself, the incremental compiler will try to process
it causing a JVM core dump.

Version-Release number of selected component (if applicable):
eclipse-lomboz-3.0-7

How reproducible:
always

Steps to Reproduce:
1. Create a new J2EE project with a web module (choose Jonas 1.4.x server)
2. Open up the default "index.jsp"
3. add the line "<%@ include file="index.jsp" %>
4. Save the file
  
Actual results:
JVM core dumps

Expected results:
Lomboz should report an error.

Additional info:
This may seem pointless as recursively including a jsp in itself is a
bad idea in the first place. However, if a user accidentally types the
wrong jsp name, the jvm will crash and the workspace can only be
recovered by manually removeing the recursive include from the jsp.
(eclipse will cause JVM crash every time the file is [re]opened)

Comment 1 Jeff Pound 2004-09-22 13:30:28 UTC
Created attachment 104121 [details]
java core

Comment 2 Jeff Pound 2004-09-22 13:32:21 UTC
*** Bug 133198 has been marked as a duplicate of this bug. ***

Comment 3 Aaron Luchko 2004-11-29 20:08:53 UTC
No longer a full crash but an Eclipse internal error does occur and an error log
is produced.

Comment 4 Andrew Overholt 2005-09-09 14:47:10 UTC
I don't get a crash, but Eclipse hangs in some sort of loop with this
continuously echoed to the command line:

Searching for valid stack frames.
Stack trace information below may not be accurate or complete. It is provided
for diagnostic purposes.

Comment 5 Alexander Kurtakov 2016-05-26 11:41:26 UTC
Lomboz is dead and Developer suite is not supported in long time.


Note You need to log in before you can comment on or make changes to this bug.