Bug 1332233 - remote_tmp filling up since upgrading to ansible 2
Summary: remote_tmp filling up since upgrading to ansible 2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ansible
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-02 14:56 UTC by Michael Göhler
Modified: 2016-06-18 18:59 UTC (History)
6 users (show)

Fixed In Version: ansible-2.1.0.0-1.fc23 ansible-2.1.0.0-1.el7 ansible-2.1.0.0-1.fc22 ansible-2.1.0.0-1.el6 ansible-2.1.0.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-31 19:57:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Göhler 2016-05-02 14:56:00 UTC
Description of problem:
copy, template and other modules leave files in remote_tmp ($HOME/.ansible/tmp or /tmp when become) after successful execution.

Version-Release number of selected component (if applicable):
ansible-2.0.1.0-2.el7.noarch

How reproducible:

Steps to Reproduce:
echo 'This is a test!' > a.out
ansible localhost -m copy -a "src=a.out dest=/tmp/b.out" -vvvv | grep PUT
rm a.out /tmp/b.out
ls -l $HOME/.ansible/tmp/ansible-tmp* /tmp/ansible-tmp*

Actual results:
Files (like $HOME/.ansible/tmp/ansible-tmp-1461941904.93-114576180700549/source) exist.

Expected results:
No temp folders left.

Additional info:
https://github.com/ansible/ansible-modules-core/issues/3572
https://github.com/ansible/ansible/issues/14917

Should be fixed in 2.0.2.0.

Comment 1 Kevin Fenzi 2016-05-02 15:24:15 UTC
I do not think it is fixed in 2.0.2.0 (although I could be wrong), when I looked it seemed to only be fixed in 2.1.

2.0.2.0 is in epel-testing, you can easily update to it and test: 

yum --enablerepo=epel-testing update ansible

Comment 2 Michael Göhler 2016-05-02 15:45:45 UTC
You are right. It's not in 2.0.2.0. Just retested it.

Comment 3 Orion Poplawski 2016-05-02 15:49:00 UTC
Looks like it may be fixed for "file" (which is what I saw locally), but maybe not for other modules?

Comment 4 Michael Göhler 2016-05-02 15:53:17 UTC
It's also fixed for "template" but not for "copy" in 2.0.2.0.

Comment 5 Toshio Ernie Kuratomi 2016-05-13 16:30:00 UTC
Looks like this fix coming in 2.1 should fix this: https://github.com/ansible/ansible/pull/15501

Comment 6 Fedora Update System 2016-05-25 16:19:38 UTC
ansible-2.1.0.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f9a2eb8d7

Comment 7 Fedora Update System 2016-05-25 16:20:02 UTC
ansible-2.1.0.0-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d31dacfabf

Comment 8 Fedora Update System 2016-05-25 16:20:18 UTC
ansible-2.1.0.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5a1e887dfc

Comment 9 Fedora Update System 2016-05-25 16:20:34 UTC
ansible-2.1.0.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aceff68672

Comment 10 Fedora Update System 2016-05-25 16:20:52 UTC
ansible-2.1.0.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9b87ab9c77

Comment 11 Fedora Update System 2016-05-26 04:53:40 UTC
ansible-2.1.0.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9b87ab9c77

Comment 12 Fedora Update System 2016-05-26 05:00:57 UTC
ansible-2.1.0.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aceff68672

Comment 13 Fedora Update System 2016-05-26 05:01:21 UTC
ansible-2.1.0.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1f9a2eb8d7

Comment 14 Fedora Update System 2016-05-26 11:46:34 UTC
ansible-2.1.0.0-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d31dacfabf

Comment 15 Fedora Update System 2016-05-26 11:47:24 UTC
ansible-2.1.0.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5a1e887dfc

Comment 16 Fedora Update System 2016-05-31 19:56:49 UTC
ansible-2.1.0.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-06-10 06:47:59 UTC
ansible-2.1.0.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-06-12 22:52:34 UTC
ansible-2.1.0.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2016-06-13 03:18:51 UTC
ansible-2.1.0.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2016-06-18 18:57:56 UTC
ansible-2.1.0.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.