Bug 1332244 - [abrt] dnfdaemon: load_yum_repo(): python3.5 killed by SIGABRT
Summary: [abrt] dnfdaemon: load_yum_repo(): python3.5 killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1332067
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdaemon
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:aee15e906cd6482b1578a8ae759...
: 1334024 1334744 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-02 15:21 UTC by Christian Stadelmann
Modified: 2016-05-10 12:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-09 07:42:22 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (253.29 KB, text/plain)
2016-05-02 15:21 UTC, Christian Stadelmann
no flags Details
File: core_backtrace (17.85 KB, text/plain)
2016-05-02 15:21 UTC, Christian Stadelmann
no flags Details
File: dso_list (10.94 KB, text/plain)
2016-05-02 15:21 UTC, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2016-05-02 15:22 UTC, Christian Stadelmann
no flags Details
File: namespaces (85 bytes, text/plain)
2016-05-02 15:22 UTC, Christian Stadelmann
no flags Details
File: proc_pid_status (1.08 KB, text/plain)
2016-05-02 15:22 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2016-05-02 15:21:50 UTC
Description of problem:
Steps to reproduce:
0. have hawkey 0.6.3-2.fc24 on your system (updated)
1. install yumex-dnf and dnfdaemon from copr timlau/yumex-dnf or fedora 24 repositories
2. start yumex-dnf
3. if yumex-dnf doesn't refresh package metadata, trigger it from sandwich menu

What happens:
dnfdaemon crashes with a segfault

What should happen:
No segfault

This regression was introduced in hawkey 0.6.3-2.fc24 and has not been present in 0.6.2-4.fc24. Also have a look at https://github.com/timlau/dnf-daemon/issues/3 .

Version-Release number of selected component:
dnfdaemon-0.3.14-1.fc24

Additional info:
reporter:       libreport-2.7.0
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/share/dnfdaemon/dnfdaemon-system
crash_function: load_yum_repo
executable:     /usr/bin/python3.5
kernel:         4.5.2-302.fc24.x86_64
pkg_fingerprint: 3D03 BDC6 DD82 F6A5
pkg_vendor:     Fedora Project COPR (timlau/yumex-dnf)
reproducible:   The problem occurs regularly
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 load_yum_repo at /usr/src/debug/hawkey-0.6.3/src/sack.c:568
 #5 hy_sack_load_repo at /usr/src/debug/hawkey-0.6.3/src/sack.c:999
 #6 load_repo at /usr/src/debug/hawkey-0.6.3/src/python/sack-py.c:455
 #7 PyCFunction_Call at /usr/src/debug/Python-3.5.1/Objects/methodobject.c:98
 #8 PyEval_EvalFrameEx at /usr/src/debug/Python-3.5.1/Python/ceval.c:4913
 #14 _PyEval_EvalCodeWithName at /usr/src/debug/Python-3.5.1/Python/ceval.c:3995
 #15 PyEval_EvalFrameEx at /usr/src/debug/Python-3.5.1/Python/ceval.c:4793
 #24 _PyEval_EvalCodeWithName at /usr/src/debug/Python-3.5.1/Python/ceval.c:3995
 #25 PyEval_EvalCodeEx at /usr/src/debug/Python-3.5.1/Python/ceval.c:4016
 #26 function_call at /usr/src/debug/Python-3.5.1/Objects/funcobject.c:632

Comment 1 Christian Stadelmann 2016-05-02 15:21:56 UTC
Created attachment 1152990 [details]
File: backtrace

Comment 2 Christian Stadelmann 2016-05-02 15:21:57 UTC
Created attachment 1152991 [details]
File: core_backtrace

Comment 3 Christian Stadelmann 2016-05-02 15:21:59 UTC
Created attachment 1152992 [details]
File: dso_list

Comment 4 Christian Stadelmann 2016-05-02 15:22:00 UTC
Created attachment 1152993 [details]
File: limits

Comment 5 Christian Stadelmann 2016-05-02 15:22:01 UTC
Created attachment 1152994 [details]
File: namespaces

Comment 6 Christian Stadelmann 2016-05-02 15:22:02 UTC
Created attachment 1152995 [details]
File: proc_pid_status

Comment 7 Sylvain Réault 2016-05-07 09:11:35 UTC
*** Bug 1334024 has been marked as a duplicate of this bug. ***

Comment 8 Tim Lauridsen 2016-05-09 07:42:22 UTC

*** This bug has been marked as a duplicate of bug 1332067 ***

Comment 9 PastorDi 2016-05-10 12:41:34 UTC
*** Bug 1334744 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.