Bug 133225 - parted throws assertion of heads < 256 during fc3test2 install
Summary: parted throws assertion of heads < 256 during fc3test2 install
Status: CLOSED DUPLICATE of bug 138419
Alias: None
Product: Fedora
Classification: Fedora
Component: parted   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-22 15:40 UTC by Tom Wood
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 18:22:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Wood 2004-09-22 15:40:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
During install of fc3test2 on a Compaq Deskpro EN (Celeron 850),
parted throws this message:

Assertion (heads < 256) at disk_dos.c:472 in function
probe_partition_for_geom() failed.

This occurs several times, eventually hanging the machine.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Boot fc3test2 CD.
2. Attempt to partition disk, either automagically or manually.
3. Watch this assertion thrown several times.
4. Watch the box lock up after a few of these.
    

Actual Results:  Install locks up.

Expected Results:  Install should have proceeded normally.

Additional info:

There are several different CHS translations available in this BIOS,
including "Off", "Bit Shift", "LBA assisted", and "Manual".  None of
the above work.

Comment 1 Jeremy Katz 2004-09-22 16:06:42 UTC
This should be fixed in rawhide with the newer version of parted
present there.

Comment 2 Pete Lancashire 2004-10-02 17:09:34 UTC
I have basically the same

White Box Pent' 133 (showing kids how one can use a PC found in
the garbage)

2 x 2GB drives, one was FC2 the other some DOS/Win95 disk

My error is sector count <= 63

At least my box does not lock up :)

-pete

Comment 3 Josi Romildo Malaquias 2004-10-16 20:58:40 UTC
I also have this same bug, but now with fedora core 3 TEST 3. So it is there yet
and should be resolved before final release. The HD I am using has a FAT32
partition used by Windows 98.

Comment 4 Bas van Hengel 2004-11-04 20:06:32 UTC
During installation of FC3-test-i386-DVD : 
many times :
"Assertion (heads > 0) at disk_dos.c 482 in function 
probe_partition_for_geom() failed".
and
"Assertion (sectors <= 63) at disk_dos.c 487 in function 
probe_partition_for_geom() failed".
PC is running Fedora 2 only.
hda is WDC WD 600AB-22BVA0 (Geom 116301/16/63
hdb is Maxtor 4D040H2 (Geom 79408/16/63

Comment 5 morne 2005-01-02 06:56:19 UTC
The same fault as all of the above, no need repeating it all.
fedora core 3 current release 1/1/2005.


Comment 6 Alan Ly 2005-01-20 19:08:13 UTC
Same problem:

Assertion (heads < 256) at disk_dos.c:486 in
function probe_partition_for_geom() failed

But I make it just pass the partion, when it's about to start install
it gives me another error, then the install cancels out. I can't find
the cause. I'm trying to install to a Western Digital Caviar SE 250GB
hard drive. My computer's a P3 733MHz, and I'm trying to dual-boot
with Windows XP Pro. This is my first time actually trying to install
Linux, and I've made Fedora my choice of distro. So I really hope to
get it working. According to the history, this seems to be a
releatively old bug, dating back to Fedora Core 2? I'm trying to
install Core 3 Final.

Comment 7 Chris Lumens 2005-01-21 18:22:56 UTC
Marking as a duplicate of a bug which was filed later, but has a whole lot more
comments/workarounds/etc. on it.  Still trying to get this problem figured out.

*** This bug has been marked as a duplicate of 138419 ***


Note You need to log in before you can comment on or make changes to this bug.