Bug 1332412 - "/etc/resolv.conf" generated by dracut doesn't contain DNS passed via "nameserver=x.x.x.x"
Summary: "/etc/resolv.conf" generated by dracut doesn't contain DNS passed via "namese...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut
Version: 7.3
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1279685
TreeView+ depends on / blocked
 
Reported: 2016-05-03 07:09 UTC by Xunlei Pang
Modified: 2017-01-25 16:59 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 08:05:07 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2530 normal SHIPPED_LIVE dracut bug fix and enhancement update 2016-11-03 14:17:01 UTC

Description Xunlei Pang 2016-05-03 07:09:10 UTC
Description of problem:
When passing kdump dns to dracut via "nameserver=x.x.x.x",
the dns provided didn't appear in the "/etc/resolv.conf".

Version-Release number of selected component (if applicable):
kexec-tools-2.0.7-38

How reproducible:

Steps to Reproduce:
1. In dhcp environment, pass DNS to dracut via nameserver=x.x.x.x" through "/proc/cmdline" or other ways like specified using directive DNS1/DNS2 in "/etc/sysconfig/network-scripts/ifcfg-<config>".

2. Configure /etc/kdump.conf to use network dump target(either nfs or ssh)
   Configure /etc/kdump.conf to enable "default shell". 
   kdumpctl restart

3. After crash, let the kdump progress fail(for example: shutdown remote network), then it will enter a shell. 

4. In the shell, "cat /etc/resolv.conf", and can't find the DNS passed in 1).

Actual results:


Expected results:
"/etc/resolv.conf" generated by dracut should contain those DNS items passed through "nameserver=x.x.x.x".

Additional info:

Comment 1 Xunlei Pang 2016-05-03 07:21:24 UTC
There is a patch("network: dhcp before parsing specified dns through cmdline") posted:
https://github.com/dracutdevs/dracut/compare/master...dracut-mailing-devs:1461665111-7385-2-git-send-email-xlpang%40redhat.com

Comment 4 Harald Hoyer 2016-07-21 09:05:21 UTC
https://errata.devel.redhat.com/advisory/24112

dracut-033.436.el7 already contains this patch

Comment 5 Marek Hruscak 2016-07-21 20:04:10 UTC
Reproduced on RHEL-7.2RC with dracut-033-359.

Comment 7 Marek Hruscak 2016-07-21 20:26:03 UTC
Side note: kernel panic was called by executing "kill -6 1" twice

Comment 10 errata-xmlrpc 2016-11-04 08:05:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html


Note You need to log in before you can comment on or make changes to this bug.