Bug 1332424 - geo-rep: address potential leak of memory
Summary: geo-rep: address potential leak of memory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 3.8
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On: 1332419
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-03 07:39 UTC by Prasanna Kumar Kalever
Modified: 2016-09-16 18:27 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8.4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1332419
Environment:
Last Closed: 2016-09-16 18:27:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-05-03 07:39:06 UTC
+++ This bug was initially created as a clone of Bug #1332419 +++

Description of problem:
address a potential leak of memory in the main() of gsyncd.c


Version-Release number of selected component (if applicable):
mainline

--- Additional comment from Vijay Bellur on 2016-05-03 03:34:32 EDT ---

REVIEW: http://review.gluster.org/14151 (geo-rep: address potential leak of memory) posted (#3) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 1 Worker Ant 2016-09-01 05:00:32 UTC
REVIEW: http://review.gluster.org/15377 (geo-rep: address potential leak of memory) posted (#1) for review on release-3.8 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Worker Ant 2016-09-01 06:16:50 UTC
REVIEW: http://review.gluster.org/15377 (geo-rep: address potential leak of memory) posted (#2) for review on release-3.8 by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Worker Ant 2016-09-07 14:05:00 UTC
COMMIT: http://review.gluster.org/15377 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit a3f6b608f5c34ca4ded05c3b7dc272d8df68345a
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Mon May 2 19:06:47 2016 +0530

    geo-rep: address potential leak of memory
    
    fix memory leak reported by clang analyzer:
    gsyncd.c:411:17: warning: Potential leak of
                     memory pointed to by 'argv'
                     in main()
    
    
    
    >BUG: 1332419
    >Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    >Reviewed-on: http://review.gluster.org/14151
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Kotresh HR <khiremat@redhat.com>
    
    Change-Id: I179fb1c095cf4d331b5910df6388dc724cb4ac96
    BUG: 1332424
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Change-Id: Id60c851c5462868630349dd4707fd94f1b83e488
    Reviewed-on: http://review.gluster.org/15377
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Niels de Vos 2016-09-12 05:39:32 UTC
All 3.8.x bugs are now reported against version 3.8 (without .x). For more information, see http://www.gluster.org/pipermail/gluster-devel/2016-September/050859.html

Comment 5 Niels de Vos 2016-09-16 18:27:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.4, please open a new bug report.

glusterfs-3.8.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-September/000060.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.