Bug 133255 - Spec file incorrectly buries MAN pages
Summary: Spec file incorrectly buries MAN pages
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-22 19:11 UTC by Rick Johnson
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 03:49:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes mandir specification. (788 bytes, patch)
2004-09-22 19:13 UTC, Rick Johnson
no flags Details | Diff

Description Rick Johnson 2004-09-22 19:11:19 UTC
Description of problem:
Spec file for Spamassassin incorrectly places mandir in front of
buildroot, causing man pages to not appear in final RPM

Version-Release number of selected component (if applicable):
3.0.0-9rc4

How reproducible:
Build RPM

  
Actual results:
Files compiled, however not included within package.

Expected results:
No errors when building package.

Additional info:
Patch to follow

Comment 1 Rick Johnson 2004-09-22 19:13:27 UTC
Created attachment 104141 [details]
Patch that fixes mandir specification.

Simply removes the %buildroot before ${_mandir} as the _mandir macro already
includes %buildroot by default.

Comment 2 Tim Waugh 2004-10-13 14:56:45 UTC
(Works for me without any extra patch.)

Comment 3 Warren Togami 2004-10-19 03:49:02 UTC
Agreed, this doesn't seem to be a problem.


Note You need to log in before you can comment on or make changes to this bug.