Bug 1332707 - Persistent volumes gets deleted the claim attached still shows as bound to PV
Summary: Persistent volumes gets deleted the claim attached still shows as bound to PV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jan Safranek
QA Contact: Wenqi He
URL:
Whiteboard: 1339041
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-03 20:56 UTC by Ryan Howe
Modified: 2017-03-08 18:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:31:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Ryan Howe 2016-05-03 20:56:43 UTC
Description of problem:
When a PV is deleted the PVC that is bound to it never updates. The PVC still shows as bound to the deleted pv. When the pv is then created again, it shows as available and the PVC still shows as bound to it.   


Version-Release number of selected component (if applicable):
3.1.1.6

How reproducible:
100%

Steps to Reproduce:
1. Create pv1
2. Create pvc1
3. Since we only have one pv the pvc will bind to it
4. Delete the PV 
5. Recreate the PV

Actual results:
- After step 4 the PVC still shows a status of bound to the PV that was deleted. 
- After step 5 the PV shows a available and the PVC stays the same. 

Expected results:
- After step 4 the PVC shows a status telling the user the PV was removed. 
- After step 5 the PV and PVC should bind

Comment 1 Liang Xia 2016-05-09 08:08:13 UTC
Also happens on openshift 3.2.0.20

Comment 2 Jan Safranek 2016-05-24 08:00:55 UTC
This should be fixed by this PR: https://github.com/kubernetes/kubernetes/pull/24331

When someone deletes a PV that is bound to a PVC, the PVC enters phase "Lost" and emits an event - the PVC has lost its PV and user has effectively lost his data. When another PV with the same name appears again, PVC moves back from "Lost" to "Bound".

Comment 4 Wenqi He 2016-06-06 05:31:53 UTC
Added test case and tried to verify, this issue still repro on below version

openshift v3.2.1.1-1-g33fa4ea
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5

Comment 5 Scott Dodson 2016-06-06 21:17:54 UTC
Jan,

This hasn't been backported to ose or even origin has it?

Comment 6 Jan Safranek 2016-06-07 07:30:58 UTC
It's fixed only in upstream Kubernetes (upcoming 1.3) and it will land in Origin in upcoming rebase.

Comment 8 Matthew Wong 2016-07-06 15:06:58 UTC
can't reproduce in Kubernetes 1.3.

Comment 9 Wenqi He 2016-07-25 03:26:56 UTC
This bug has been fixed on below version:
openshift v3.3.0.9
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git

Changing the status to verified.

Comment 11 errata-xmlrpc 2016-09-27 09:31:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.