Bug 133273 - should autogenerate account name from real name
should autogenerate account name from real name
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-22 16:30 EDT by Colin Walters
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 13:06:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2004-09-22 16:30:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
This is a relatively minor thing, but one improvement I think we could
do to firstboot is have the real name field be above the account name
one.  When I first start typing in my real name, a sensible account
name (last name + first letter of first name maybe) should be
automatically generated from that.  

Of course the user should still be able to override this by deleting
the autogenerated name and retyping it.

Version-Release number of selected component (if applicable):
firstboot-1.3.25-1

How reproducible:
Always

Steps to Reproduce:
1. Enter real name
2. Account name doesn't update

    

Additional info:
Comment 1 Chris Lumens 2005-09-23 13:06:06 EDT
There are a variety of schemes that could be used to come up with account names
and we're likely to not pick one that most people would want.  In addition, lots
of people are going to have names that do not translate well to usernames (due
to special characters, etc.) or will want to use something completely unrelated
to their real name (a handle, nickname, etc.)
Comment 2 Colin Walters 2005-09-23 13:35:22 EDT
Point by point:

Variety of schemes - sure, but if your organization enforces a scheme,
autogenerating a default doesn't hurt, you just retype it.  I bet most
enterprises don't have their end users go through firstboot anyways.

One most people would want - If you care, you override the suggestion

Names that don't translate to Unix account names - This is a *good* reason to
autogenerate suggested account names.  It might not be obvious to a new Fedora
user that they can't use non-ASCII in their account name, by autogenerating a
suggestion we make it clearer.

Will want to use something unrelated - Again, just override it, it's not hurting
these people


Finally, look at it this way:  While a lot of tech workstation users may care
about the account name because they're Unix nerds, if we want Fedora to be a
more mainstream OS, we should hide/background implementation details like the
Unix account name in favor of presenting things to the user in terms that make
sense to them, like their real name.  So a corresponding change would be to make
GDM display a list of users with their full real name that they could pick from.

Note You need to log in before you can comment on or make changes to this bug.