Bug 133276 - Nautilus crashes when mouning disks containing files named in Japanese
Summary: Nautilus crashes when mouning disks containing files named in Japanese
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-09-22 20:34 UTC by Takayuki Ogawa
Modified: 2015-01-04 22:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-16 03:21:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Eerror message of /var/log/messages (7.72 KB, text/plain)
2004-09-22 20:39 UTC, Takayuki Ogawa
no flags Details

Description Takayuki Ogawa 2004-09-22 20:34:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
As I plugged in an USB memory stick formatted with vfat filesystem
containing files named in Japanese, the device is mounted automatically.
If the device does not include no file titled in Japanese, it works
corrently. But, if it includes files titled in Japanese, Nautilus
crashes immediately.

When the device is plugged in, the following description is added to
/etc/fstab
/dev/sda1               /media/usbdisk          vfat   
noauto,user,exec,kudzu,noatime,sync 0 0

but I mount it manually with "iocharset=utf8" option, it works correctly.


Version-Release number of selected component (if applicable):
hal-0.2.98-4

How reproducible:
Always

Steps to Reproduce:
1. Boot system with GNOME.
2. Plug in an USB memory stick formatted with vfat filesystem
containing files named in Japanese.
3.


Actual Results:  Nautilus is crashed and become unable to unmount the
device.


Expected Results:  The storage device should be mounted with
appropriate option such as
iocharset=utf8
to make the files named in Japanese readable correctly.


Additional info:

The present kernel version is "kernel-2.6.8-1.541".

Comment 1 Takayuki Ogawa 2004-09-22 20:39:23 UTC
Created attachment 104144 [details]
Eerror message of /var/log/messages

Comment 2 David Zeuthen 2004-09-22 21:07:58 UTC
This is not a hal bug - it looks more to me like a kernel or Nautilus
bug. Reassigning to Nautilus for now.

Comment 3 Alexander Larsson 2004-09-23 07:13:43 UTC
Surely this is a kernel bug, there is even an oops in the log.

Comment 4 Sitsofe Wheeler 2004-12-01 23:46:37 UTC
This sounds similar to bug 129966

Comment 5 Dave Jones 2005-07-15 17:45:46 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 6 Takayuki Ogawa 2005-07-16 02:25:36 UTC
I tried mounting my usb flash memory both Fedora Core 3 and Fedora Core 4, and
the lastest kernel seems to work very well.
In fact, I have not faced with this bug since I updated the kernel of Fedora
Core 3 for a long time before. I'm sorry that I don't remember what the kernel
version is. But I think this bug was related to bug #129966.

Thank you for fixing bugs.



Note You need to log in before you can comment on or make changes to this bug.