Bug 1332966 - Add Provides: in spec file for langpacks plugin
Summary: Add Provides: in spec file for langpacks plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: Red_Hat_Enterprise_Linux-Release_Notes-7-fr-FR
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Radek Bíba
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-04 12:39 UTC by Parag Nemade
Modified: 2016-11-04 08:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 08:25:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
just a testing proof (56.13 KB, image/png)
2016-07-13 04:48 UTC, Parag Nemade
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2544 normal SHIPPED_LIVE Red Hat Enterprise Linux 7.3 Release Notes 2016-11-03 14:19:25 UTC

Description Parag Nemade 2016-05-04 12:39:48 UTC
Description of problem:
Just add following line in spec file and build new package.
Provides:      Red_Hat_Enterprise_Linux-Release_Notes-7-fr = %{version}-%{release}


Version-Release number of selected component (if applicable):
Red_Hat_Enterprise_Linux-Release_Notes-7-fr-FR-7-2.1.el7.src.rpm

How reproducible:
always

Steps to Reproduce:
1. repoquery --provides Red_Hat_Enterprise_Linux-Release_Notes-7-fr-FR
2.
3.

Actual results:
ed_Hat_Enterprise_Linux-Release_Notes-7-fr-FR = 7-2.1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-fr_FR = 7-2.1.el7

Expected results:
ed_Hat_Enterprise_Linux-Release_Notes-7-fr-FR = 7-2.1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-fr = 7-2.1.el7

Additional info:
This same thing applies to all other packages except pt_BR, zh_CN, zh_TW.

Please update the package asap.

Comment 1 Parag Nemade 2016-05-04 13:07:07 UTC
I have gone through the existing package list. These packages need to follow what all other projects are following. e.g.

Always use language names as

Red_Hat_Enterprise_Linux-Release_Notes-7-de-DE => Red_Hat_Enterprise_Linux-Release_Notes-7-de
Red_Hat_Enterprise_Linux-Release_Notes-7-es-ES => Red_Hat_Enterprise_Linux-Release_Notes-7-es
Red_Hat_Enterprise_Linux-Release_Notes-7-fr-FR => Red_Hat_Enterprise_Linux-Release_Notes-7-fr
Red_Hat_Enterprise_Linux-Release_Notes-7-it-IT => Red_Hat_Enterprise_Linux-Release_Notes-7-it
Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP => Red_Hat_Enterprise_Linux-Release_Notes-7-ja
Red_Hat_Enterprise_Linux-Release_Notes-7-ko-KR => Red_Hat_Enterprise_Linux-Release_Notes-7-ko
Red_Hat_Enterprise_Linux-Release_Notes-7-pt-BR => Red_Hat_Enterprise_Linux-Release_Notes-7-pt_BR
Red_Hat_Enterprise_Linux-Release_Notes-7-ru-RU => Red_Hat_Enterprise_Linux-Release_Notes-7-ru
Red_Hat_Enterprise_Linux-Release_Notes-7-zh-CN => Red_Hat_Enterprise_Linux-Release_Notes-7-zh_CN
Red_Hat_Enterprise_Linux-Release_Notes-7-zh-TW => Red_Hat_Enterprise_Linux-Release_Notes-7-zh_TW
Red_Hat_Enterprise_Linux-Release_Notes-7-as-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-as
Red_Hat_Enterprise_Linux-Release_Notes-7-bn-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-bn_IN
Red_Hat_Enterprise_Linux-Release_Notes-7-en-US => Red_Hat_Enterprise_Linux-Release_Notes-7-en_US
Red_Hat_Enterprise_Linux-Release_Notes-7-gu-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-gu
Red_Hat_Enterprise_Linux-Release_Notes-7-hi-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-hi
Red_Hat_Enterprise_Linux-Release_Notes-7-kn-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-kn
Red_Hat_Enterprise_Linux-Release_Notes-7-ml-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-ml
Red_Hat_Enterprise_Linux-Release_Notes-7-mr-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-mr
Red_Hat_Enterprise_Linux-Release_Notes-7-or-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-or
Red_Hat_Enterprise_Linux-Release_Notes-7-pa-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-pa
Red_Hat_Enterprise_Linux-Release_Notes-7-ta-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-ta
Red_Hat_Enterprise_Linux-Release_Notes-7-te-IN => Red_Hat_Enterprise_Linux-Release_Notes-7-te

Please note here full langcodes here for en_US, bn_IN, zh_CN, zh_TW, pt_BR.

Comment 2 Parag Nemade 2016-07-04 12:40:37 UTC
Why is it that still there is no interest for this bug fixing? I really can't help here. Packages need to be renamed.

Comment 3 Radek Bíba 2016-07-04 13:15:50 UTC
Coincidentally, I begun making the changes this morning. I already have the new .spec files for those languages whose packages had updates in 7.2 and contain links to online release notes. However, I won't be able to push the changes to rebuild the packages until the components are approved for 7.3 and this bug fully ACKed. I may also need to have the -IN packages unblocked for the 7.3 compose. PM has already been contacted in this regard, too.

Comment 4 Radek Bíba 2016-07-04 13:18:53 UTC
s/I begun/I began/ :)

Comment 7 Radek Bíba 2016-07-08 07:52:12 UTC
Could you please check if the output below is the expected result? The command was run on a system where the updated packages were installed, together with the packages that didn't need updating (where full language codes are necessary, as you wrote).

# for lang in {as-IN,bn-IN,de-DE,en-US,es-ES,fr-FR,gu-IN,hi-IN,it-IT,ja-JP,kn-IN,ko-KR,ml-IN,mr-IN,or-IN,pa-IN,pt-BR,ru-RU,ta-IN,te-IN,zh-CN,zh-TW}; do echo $lang:; rpm -q --provides Red_Hat_Enterprise_Linux-Release_Notes-7-$lang | grep ^R; echo; done
as-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-as = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-as-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-as_IN = 3-1.el7

bn-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-bn-IN = 3-2.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-bn_IN = 3-2.el7

de-DE:
Red_Hat_Enterprise_Linux-Release_Notes-7-de = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-de-DE = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-de_DE = 7-3.el7

en-US:
Red_Hat_Enterprise_Linux-Release_Notes-7-en-US = 7-2.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-en_US = 7-2.el7

es-ES:
Red_Hat_Enterprise_Linux-Release_Notes-7-es = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-es-ES = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-es_ES = 7-3.el7

fr-FR:
Red_Hat_Enterprise_Linux-Release_Notes-7-fr = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-fr-FR = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-fr_FR = 7-3.el7

gu-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-gu = 3-2.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-gu-IN = 3-2.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-gu_IN = 3-2.el7

hi-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-hi = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-hi-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-hi_IN = 3-1.el7

it-IT:
Red_Hat_Enterprise_Linux-Release_Notes-7-it = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-it-IT = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-it_IT = 7-3.el7

ja-JP:
Red_Hat_Enterprise_Linux-Release_Notes-7-ja = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ja-JP = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ja_JP = 7-3.el7

kn-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-kn = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-kn-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-kn_IN = 3-1.el7

ko-KR:
Red_Hat_Enterprise_Linux-Release_Notes-7-ko = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ko-KR = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ko_KR = 7-3.el7

ml-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-ml = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ml-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ml_IN = 3-1.el7

mr-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-mr = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-mr-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-mr_IN = 3-1.el7

or-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-or = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-or-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-or_IN = 3-1.el7

pa-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-pa = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-pa-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-pa_IN = 3-1.el7

pt-BR:
Red_Hat_Enterprise_Linux-Release_Notes-7-pt-BR = 7-2.1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-pt_BR = 7-2.1.el7

ru-RU:
Red_Hat_Enterprise_Linux-Release_Notes-7-ru = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ru-RU = 7-3.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ru_RU = 7-3.el7

ta-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-ta = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ta-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-ta_IN = 3-1.el7

te-IN:
Red_Hat_Enterprise_Linux-Release_Notes-7-te = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-te-IN = 3-1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-te_IN = 3-1.el7

zh-CN:
Red_Hat_Enterprise_Linux-Release_Notes-7-zh-CN = 7-2.2.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-zh_CN = 7-2.2.el7

zh-TW:
Red_Hat_Enterprise_Linux-Release_Notes-7-zh-TW = 7-2.1.el7
Red_Hat_Enterprise_Linux-Release_Notes-7-zh_TW = 7-2.1.el7

The versions are inconsistent across the language variants, but they've been inconsistent before, too, and it shouldn't be a problem. The updated packages have newer NVRs, so they're installable, anyway.

Comment 8 Parag Nemade 2016-07-13 04:48:45 UTC
Created attachment 1179052 [details]
just a testing proof

Thanks Radek for this change in RHEL7 release notes packages. Along with new yum-langpacks-0.4.2-7 build, I can see langpacks is pulling required packages for the locales selected in anaconda installation.

Comment 9 Radek Bíba 2016-07-13 06:49:17 UTC
Comment on attachment 1179052 [details]
just a testing proof

Correcting the MIME type of the attachment so that it can be viewed.

Comment 10 Radek Bíba 2016-07-13 06:50:40 UTC
Thanks Parag.

Comment 12 errata-xmlrpc 2016-11-04 08:25:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2544.html


Note You need to log in before you can comment on or make changes to this bug.