Bug 1332978 - update to a newer release or merge with pypy package
Summary: update to a newer release or merge with pypy package
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pypy3
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1353595 (view as bug list)
Depends On: 1307889
Blocks: ZedoraTracker PPCTracker
TreeView+ depends on / blocked
 
Reported: 2016-05-04 13:10 UTC by Dan Horák
Modified: 2016-11-19 21:18 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-19 21:18:30 UTC


Attachments (Terms of Use)

Description Dan Horák 2016-05-04 13:10:11 UTC
The last successful build of pypy3 is pypy3-2.4.0-3.fc24. It would be very useful to rebase it to later version because they include support for additional architectures - ppc64/ppc64le for sure, maybe also s390 or aarch64.

Isn't it possible to merge pypy3 with pypy packages and build both py2 and py3 specific versions from a common package?

Comment 1 Peter Robinson 2016-05-04 13:12:34 UTC
> Isn't it possible to merge pypy3 with pypy packages and build both py2 and
> py3 specific versions from a common package?

I believe originally the reason for the separate base package was because py3 support was a fork/separate tarball but this isn't the case now since v4 with both py2 and py3 support being buildable from the same tar file.

Comment 2 Miro Hrončok 2016-05-05 11:41:55 UTC
Oh, I didn't know that

http://pypy.org/download.html still lists pypy3 as the one with Python 3 support and 2.4.0 as the latest version.

Comment 3 Dan Horák 2016-05-12 10:34:40 UTC
Hm, sounds we are out of luck then. Peter, what's the source of your information?

Comment 4 Peter Robinson 2016-05-12 10:37:54 UTC
I'm sure it was on their main site, when I have a moment I'll see if I can find it again, it was a while ago that I read it.

Comment 5 Peter Robinson 2016-10-15 14:31:21 UTC
So there's now a new 5.5.0 release with support for a number of new architectures:

    x86 machines on most common operating systems except Windows 
    newer ARM hardware (ARMv6 or ARMv7, with VFPv3) running Linux 
    big- and little-endian variants of PPC64 running Linux 
    s390x running Linux

https://morepypy.blogspot.co.uk/2016/10/pypy3-550-released.html

Comment 6 Miro Hrončok 2016-10-15 16:56:10 UTC
Cool. I already have an alpha ready in https://copr.fedorainfracloud.org/coprs/churchyard/pypy33/ will try to package this ASAP.

The real question is, shall I do rawhide only? Probably yes, because the virtualenvs tend to be broken between pypy releases.

Comment 7 Miro Hrončok 2016-10-15 17:19:10 UTC
I'm now stuck at:

    Exception: OpenSSL version >= 1.1 not supported yet.

Comment 8 Zbigniew Jędrzejewski-Szmek 2016-10-15 17:42:29 UTC
I'd go for F25 too. It'd be much nicer to have this in stable Fedora for next 6 months.

And it'd get around the OpenSSL issue :) A bit later the openssl-1.0-compat-devel package will almost certainly be added to rawhide, or pypy will get support for 1.1. Either way, it makes sense to proceed without openssl-1.1 for now.

Comment 9 Miro Hrončok 2016-10-15 17:52:46 UTC
Ye, I'm trying to build for F25 to have it ready.

Comment 10 Miro Hrončok 2016-10-21 22:32:27 UTC
*** Bug 1353595 has been marked as a duplicate of this bug. ***

Comment 11 Miro Hrončok 2016-10-22 10:35:26 UTC
I'm having trouble with https://github.com/yyuu/pyenv-virtualenv/issues/188 which would be a blocker.

    $ python3 -m virtualenv -p /usr/bin/pypy3 pypy3
    (exceptions, errors, problems)

But I'm doing it on F23, so will also test on F25 to see if it perhaps does work there.

In case anyone would like to help with that see https://copr.fedorainfracloud.org/coprs/churchyard/pypy33

Comment 12 Miro Hrončok 2016-10-22 10:57:51 UTC
$ python3 -m virtualenv -p /usr/bin/pypy3 pypy3

works on F25. will test with tox, but I think it will work as well.

Comment 13 Miro Hrončok 2016-10-22 12:12:16 UTC
It works. Going to build in rawhide.

Comment 15 Miro Hrončok 2016-10-22 12:18:57 UTC
Forgot to commit the sources, sorry about that.

http://koji.fedoraproject.org/koji/taskinfo?taskID=16163590

Comment 16 Peter Robinson 2016-10-22 12:37:27 UTC
And you'll likely want to ExcludeArch aarch64 as I'm not sure (sadly) it's supported yet (although would love to be proven wrong)

Comment 17 Miro Hrončok 2016-10-22 14:17:30 UTC
Find out the hard way :(

http://koji.fedoraproject.org/koji/taskinfo?taskID=16164154

Comment 18 Miro Hrončok 2016-10-23 10:51:34 UTC
I'm getting "Memory exhausted" on armv7hl twice in a row.

Will try to get it build less parallel and see if that works.

Comment 19 Miro Hrončok 2016-10-23 11:03:20 UTC
Hmm, there is http://pkgs.fedoraproject.org/cgit/rpms/pypy.git/commit/pypy.spec?id=5164c65be2c803608d92eb05cf38fd269c7bd402 - I'll try to use the line with PYPY_GC_MAX_DELTA.

Comment 20 Miro Hrončok 2016-10-24 07:11:36 UTC
So making it less parallel doesn't help And I was unable to port the PYPY_GC_MAX_DELTA command to this package, as I have no idea how does that work.

Michal, could you please have a look? It was in your commit in pypy.

Comment 21 Michal Cyprian 2016-10-24 09:07:26 UTC
This command changes settings of PyPy's garbage collector to reduce RAM usage. It don't know any details, I put command from documentation to the specfile and it worked for PyPy2. Documentation links:
http://pypy.org/download.html
http://doc.pypy.org/en/latest/gc_info.html

Comment 22 Miro Hrončok 2016-11-03 11:23:52 UTC
I'm sorry. I don't have time to fix this in time.

Zbigniew, if you want to get this to Fedora 25, please have a look at it. If you don't have time as well, ask Michal.

Also, we could ask for help on python-devel@

Comment 23 Zbigniew Jędrzejewski-Szmek 2016-11-13 23:28:44 UTC
I switched the linker to gold (but not on ppc64*, because it isn't available there), which got around the linking issues on arm and made some small hack in the build process. sharkcz fixed the build on s390x by bumping the minimum architecture version to z10.

Comment 24 Fedora Update System 2016-11-13 23:30:51 UTC
pypy3-5.5.0-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6f621ad361

Comment 25 Miro Hrončok 2016-11-14 07:59:59 UTC
You are awesome! I'll test the build and give karma accordingly.

Comment 26 Fedora Update System 2016-11-15 13:26:24 UTC
pypy3-5.5.0-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6f621ad361

Comment 27 Fedora Update System 2016-11-19 21:18:30 UTC
pypy3-5.5.0-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.