Bug 1333000 - :latest is confusing
Summary: :latest is confusing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-04 13:43 UTC by Dan McPherson
Modified: 2018-09-04 15:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:32:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
LatestBuilderImage (136.25 KB, image/png)
2016-05-31 01:54 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Dan McPherson 2016-05-04 13:43:41 UTC
Description of problem:

When selecting a template, there are options with versions and an extra option for :latest.  I know what this means, but the way it's displayed is confusing.  It could easily be read as you either want ruby 2.0, 2.2, or possibly something newer called latest.  It isn't obvious I am making a choice about always staying on the latest.

Adding the current version to the box would be helpful (Ex: Currently 2.2).  Then you could see there are two versions with ruby 2.2 and you might be able to figure out that latest means something other than just picking a current version.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a project and go to Add to Project
2. Be confused

Comment 1 Jessica Forrester 2016-05-05 19:25:28 UTC
We use to have the version there, I worried that would make people think they were getting that version, and wouldnt realize that latest meant the version they are using could change at any time.  I think either way we do it there are concerns, which is why we are re-evaluating how this page is organized.

Comment 2 openshift-github-bot 2016-05-26 18:29:37 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/d5e106d3a53a057317dcb49687b764e993f56cba
Bug 1333000 - warning for the latest builder image

Comment 3 Jessica Forrester 2016-05-26 19:35:36 UTC
fixed in origin, will not be backported to 3.2.x so can just test origin to validate this is fixed

Comment 4 Yadan Pei 2016-05-30 09:06:21 UTC
Trying to figure out a better way to build origin-web-console into origin, then I could check again

Comment 5 Yadan Pei 2016-05-31 01:53:49 UTC
Hi Jessica,

I tried to verify the fix in following steps http://pastebin.test.redhat.com/378725


But I didn't see the warning for the latest builder image when <builderimage>:latest is selected

Could you please help check if the verification steps are correct, thanks

Comment 6 Yadan Pei 2016-05-31 01:54:22 UTC
Created attachment 1163000 [details]
LatestBuilderImage

Comment 7 Yadan Pei 2016-06-03 09:08:47 UTC
Checked again today with follow steps, http://pastebin.test.redhat.com/380193

Still didn't see the message when <builderimage>:latest is selected

Comment 9 Yadan Pei 2016-07-15 09:41:10 UTC
Checked against devenv-rhel7_4594,

When image with :latest tag is selected,there's warning on create/fromimage page 
"
This builder image tracks the latest version of the <Image_Name> image, which could be updated to a newer major version in the future. If your application will not run on a different major version go back and choose a specific version. 
"
Here 'back' is a link to reselect images.

It works pretty well on ORIGIN

I will check when new OSE puddle(containing our changes) is ready

Comment 10 Yadan Pei 2016-07-18 06:23:04 UTC
Checked on 
openshift v3.3.0.6
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git

Fixes are merged to OCP,move to VERIFIED

Comment 12 errata-xmlrpc 2016-09-27 09:32:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.