Bug 1333039 - No capsule install command to install discovery plugin
Summary: No capsule install command to install discovery plugin
Keywords:
Status: CLOSED DUPLICATE of bug 1410141
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-04 14:40 UTC by Justin Sherrill
Modified: 2020-01-17 15:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-15 14:29:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of capsule after doing steps showing discovery (133.45 KB, image/png)
2016-09-19 19:23 UTC, Chris Roberts
no flags Details

Description Justin Sherrill 2016-05-04 14:40:53 UTC
Description of problem:

On the capsule there is not an installer option to install the discovery plugin currently.  Its not needed on the capsule but wouldn't hurt if its there.


Version-Release number of selected component (if applicable):
6.2.0 beta

How reproducible:
always

Steps to Reproduce:
1.  Install a capsule
2.  Try to install the discovery plugin using the installer.  Its likely something like  --enable-foreman-proxy-plugin-discovery

Additional info:

foreman-installer --help | grep discover  

shows no entries.

Comment 1 Justin Sherrill 2016-05-04 14:42:36 UTC
note the work around is to simply yum install rubygem-smart_proxy_discovery

Comment 5 Chris Roberts 2016-09-19 19:22:16 UTC
Works on 6.2.2 

[root@capsule ~]# yum install rubygem-smart_proxy_discovery
Loaded plugins: product-id, search-disabled-repos, security, subscription-
              : manager
Setting up Install Process
RH_Engineering_RH_Internal_ddns                          | 2.1 kB     00:00     
RH_Engineering_VMWare_Tools6                             | 1.8 kB     00:00     
rhel-6-server-rhev-agent-rpms                            | 1.9 kB     00:00     
rhel-6-server-rpms                                       | 2.0 kB     00:00     
rhel-6-server-satellite-capsule-6.2-rpms                 | 2.3 kB     00:00     
rhel-server-rhscl-6-rpms                                 | 2.0 kB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package rubygem-smart_proxy_discovery.noarch 0:1.0.3-3.el6sat will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package   Arch   Version        Repository                                Size
================================================================================
Installing:
 rubygem-smart_proxy_discovery
           noarch 1.0.3-3.el6sat rhel-6-server-satellite-capsule-6.2-rpms  20 k

Transaction Summary
================================================================================
Install       1 Package(s)

Total download size: 20 k
Installed size: 41 k
Is this ok [y/N]: y
Downloading Packages:
rubygem-smart_proxy_discovery-1.0.3-3.el6sat.noarch.rpm  |  20 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : rubygem-smart_proxy_discovery-1.0.3-3.el6sat.noarch          1/1 
  Verifying  : rubygem-smart_proxy_discovery-1.0.3-3.el6sat.noarch          1/1 

Installed:
  rubygem-smart_proxy_discovery.noarch 0:1.0.3-3.el6sat                         

Complete!
[root@capsule ~]# katello-service restart
Stopping httpd:                                            [  OK  ]
celery multi v3.1.11 (Cipater)
> Stopping nodes...
	> resource_manager@capsule.toledo.lan: QUIT -> 23092
> Waiting for 1 node -> 23092.....
	> resource_manager@capsule.toledo.lan: OK

celery init v10.0.
Using config script: /etc/default/pulp_resource_manager
celery multi v3.1.11 (Cipater)
> Stopping nodes...
	> reserved_resource_worker-2@capsule.toledo.lan: QUIT -> 23332
	> reserved_resource_worker-3@capsule.toledo.lan: QUIT -> 23351
	> reserved_resource_worker-0@capsule.toledo.lan: QUIT -> 23299
	> reserved_resource_worker-1@capsule.toledo.lan: QUIT -> 23313
> Waiting for 4 nodes -> 23332, 23351, 23299, 23313........
	> reserved_resource_worker-2@capsule.toledo.lan: OK
> Waiting for 3 nodes -> 23351, 23299, 23313....
	> reserved_resource_worker-3@capsule.toledo.lan: OK
> Waiting for 2 nodes -> 23299, 23313....
	> reserved_resource_worker-0@capsule.toledo.lan: OK
> Waiting for 1 node -> 23313....
	> reserved_resource_worker-1@capsule.toledo.lan: OK

celery init v10.0.
Using config script: /etc/default/pulp_workers
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
Stopping pulp_celerybeat... OK
Stopping foreman-proxy:                                    [  OK  ]
Stopping Qpid AMQP daemon:                                 [  OK  ]
Shutting down qdrouterd services:                          [  OK  ]
Stopping mongod:                                           [  OK  ]
Success!

[root@capsule ~]# foreman-installer --scenario capsule -v
[ INFO 2016-09-19 15:19:04 verbose] Executing hooks in group pre_migrations
[ INFO 2016-09-19 15:19:04 verbose] All hooks in group pre_migrations finished
[ INFO 2016-09-19 15:19:04 verbose] Executing hooks in group boot
[ INFO 2016-09-19 15:19:04 verbose] All hooks in group boot finished
[ INFO 2016-09-19 15:19:04 verbose] Executing hooks in group init
[ INFO 2016-09-19 15:19:04 verbose] All hooks in group init finished
[ INFO 2016-09-19 15:19:04 verbose] Loading default values from puppet modules...
[ INFO 2016-09-19 15:19:04 verbose] ... finished
[ INFO 2016-09-19 15:19:04 verbose] Executing hooks in group pre_values
[ INFO 2016-09-19 15:19:04 verbose] All hooks in group pre_values finished
[ INFO 2016-09-19 15:19:04 verbose] Executing hooks in group pre_validations
[ INFO 2016-09-19 15:19:04 verbose] All hooks in group pre_validations finished
[ INFO 2016-09-19 15:19:04 verbose] Running validation checks
[ INFO 2016-09-19 15:19:05 verbose] Executing hooks in group pre_commit
[ INFO 2016-09-19 15:19:05 verbose] All hooks in group pre_commit finished
[ INFO 2016-09-19 15:19:05 verbose] Executing hooks in group pre
[ INFO 2016-09-19 15:19:05 verbose] All hooks in group pre finished
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ INFO 2016-09-19 15:19:05 verbose]  Loading facts
[ WARN 2016-09-19 15:19:06 verbose]  Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
[ WARN 2016-09-19 15:19:11 verbose]  Scope(Concat::Fragment[Apache ports header]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[Listen 80]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[NameVirtualHost *:80]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[Listen 8443]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[NameVirtualHost *:8443]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[Listen 5000]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[NameVirtualHost *:5000]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[Listen 443]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[NameVirtualHost *:443]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[Listen 8140]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:12 verbose]  Scope(Concat::Fragment[NameVirtualHost *:8140]): The $ensure parameter to concat::fragment is deprecated and has no effect.
[ WARN 2016-09-19 15:19:13 verbose]  Compiled catalog for capsule.toledo.lan in environment production in 7.18 seconds
[ INFO 2016-09-19 15:19:17 verbose]  Applying configuration version '1474312746'
[ WARN 2016-09-19 15:19:17 verbose]  /Stage[main]/Capsule/Certs::Tar_extract[/root/capsule2.tar.gz]/Exec[extract /root/capsule2.tar.gz]/returns: executed successfully
[ WARN 2016-09-19 15:19:20 verbose]  /Stage[main]/Apache::Mod::Ssl/File[ssl.conf]/ensure: defined content as '{md5}030cdd1e5b44c0176ca4c7932996e7e8'
[ INFO 2016-09-19 15:19:20 verbose]  /Stage[main]/Apache::Mod::Ssl/File[ssl.conf]: Scheduling refresh of Class[Apache::Service]
[ WARN 2016-09-19 15:19:20 verbose]  /File[/var/run/mongodb/mongodb.pid]/seluser: seluser changed 'unconfined_u' to 'system_u'
[ INFO 2016-09-19 15:19:20 verbose]  Class[Mongodb::Server::Config]: Scheduling refresh of Class[Mongodb::Server::Service]
[ INFO 2016-09-19 15:19:20 verbose]  Class[Mongodb::Server::Service]: Scheduling refresh of Service[mongodb]
[ WARN 2016-09-19 15:19:28 verbose]  /Stage[main]/Mongodb::Server::Service/Service[mongodb]: Triggered 'refresh' from 1 events
[ INFO 2016-09-19 15:19:30 verbose]  Class[Apache::Service]: Scheduling refresh of Service[httpd]
[ WARN 2016-09-19 15:19:32 verbose]  /Stage[main]/Apache::Service/Service[httpd]: Triggered 'refresh' from 1 events
[ WARN 2016-09-19 15:19:32 verbose]  Finished catalog run in 16.83 seconds
[ INFO 2016-09-19 15:19:34 verbose] Puppet has finished, bye!
[ INFO 2016-09-19 15:19:34 verbose] Executing hooks in group post
  Success!
  The full log is at /var/log/foreman-installer/capsule.log
[ INFO 2016-09-19 15:19:34 verbose] All hooks in group post finished

see screenshot - removing urgent status

Comment 6 Chris Roberts 2016-09-19 19:23:01 UTC
Created attachment 1202619 [details]
screenshot of capsule after doing steps showing discovery

Comment 7 Lukas Zapletal 2016-09-22 12:33:42 UTC
This is on the installer team, perhaps something in the capsule scenario, I don't know exactly. This was working fine in 6.1.

Comment 10 Chris Roberts 2017-02-15 14:29:29 UTC

*** This bug has been marked as a duplicate of bug 1410141 ***


Note You need to log in before you can comment on or make changes to this bug.