Bug 1333075 - Ansible requires python2 and Xenial does not have it by default
Summary: Ansible requires python2 and Xenial does not have it by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Christina Meno
QA Contact: Daniel Horák
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-04 15:26 UTC by Ken Dreyer (Red Hat)
Modified: 2016-08-23 19:49 UTC (History)
8 users (show)

Fixed In Version: ceph-installer-1.0.7-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:49:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Ken Dreyer (Red Hat) 2016-05-04 15:26:41 UTC
Description of problem:
When ceph-installer tries to run Ansible on Xenial cluster nodes, these nodes might not have Python 2.7 installed, so Ansible will fail.

Version-Release number of selected component (if applicable):
ceph-installer-1.0.6

How reproducible:
always

Steps to Reproduce:
1. Install a minimal version of Xenial (for example, an Ubuntu Xenial cloud
   image)
2. Verify that the minimal version of Xenial does not have the "python" package
   present.
3. Proceed with the installation as normal:

 - Run the bootstrap script on the node (for example `curl
   http://installer-node:8181/setup/ | bash`)

 - Next, try to manage the node with ceph-installer (for example, POST to curl
   http://installer-node:8181/api/mon/install to install the ceph-mon software
   on the Xenial node, or any other Ansible action)


Actual results:
Ansible will fail because Python 2 is not present.

Expected results:
ceph-installer is able to manage Xenial nodes with Ansible, and the administrator does not need to manually install "python" on the Xenial nodes ahead of time.

Additional info:
The fix will be to have the bootstrap script explicitly ensure that Python 2 is present for Ansible to use. https://github.com/ceph/ceph-installer/pull/144

Comment 5 Daniel Horák 2016-08-02 10:45:46 UTC
Tested on:
USM Server/ceph-installer server RHEL 7.2:
  ceph-installer-1.0.14-1.el7scon.noarch

Ceph Nodes Ubuntu 16.04.

>> VERIFIED

Comment 7 errata-xmlrpc 2016-08-23 19:49:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.