Bug 1333087 - Mounting an AWS volume returns an error that looks incorrect: Could not attach EBS Disk "placeholder-for-provisioning": Invalid format for AWS volume
Summary: Mounting an AWS volume returns an error that looks incorrect: Could not attac...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Storage
Version: 3.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Mark Turansky
QA Contact: Jianwei Hou
URL:
Whiteboard:
: 1334011 (view as bug list)
Depends On:
Blocks: OSOPS_V3
TreeView+ depends on / blocked
 
Reported: 2016-05-04 15:46 UTC by Stefanie Forrester
Modified: 2016-05-23 15:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-23 15:10:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stefanie Forrester 2016-05-04 15:46:02 UTC
Description of problem:

User received this error when provisioning a new PV in dev-preview-int: Could not attach EBS Disk "placeholder-for-provisioning"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

- apiVersion: v1
  count: 1
  firstTimestamp: 2016-05-04T14:33:04Z
  involvedObject:
    apiVersion: v1
    kind: Pod
    name: jenkins-1-c1629
    namespace: jwforres
    resourceVersion: "3983188"
    uid: fcddad4f-1204-11e6-98bd-0a1d348c34bb
  kind: Event
  lastTimestamp: 2016-05-04T14:33:04Z
  message: 'Unable to mount volumes for pod "jenkins-1-c1629_jwforres(fcddad4f-1204-11e6-98bd-0a1d348c34bb)":
    Could not attach EBS Disk "placeholder-for-provisioning": Invalid format for AWS
    volume (aws:///placeholder-for-provisioning)'
  metadata:
    creationTimestamp: 2016-05-04T14:33:04Z
    deletionTimestamp: 2016-05-04T16:33:04Z
    name: jenkins-1-c1629.144b63ef823f1dc1
    namespace: jwforres
    resourceVersion: "3983383"
    selfLink: /api/v1/namespaces/jwforres/events/jenkins-1-c1629.144b63ef823f1dc1
    uid: 1c7cf10f-1205-11e6-abb2-0ada84b8265d
  reason: FailedMount
  source:
    component: kubelet
    host: ip-172-31-14-20.ec2.internal
  type: Warning

Comment 1 Mark Turansky 2016-05-04 15:57:17 UTC
This is an Online bug, not a provisioning/storage bug.  I am taking ownership from Brad.

Comment 2 Mark Turansky 2016-05-04 16:33:53 UTC
This is more of a usability improvement than blocker bug.

The PV will eventually get provisioned.  The "placeholder" ID is replaces with a real ID.

The issue is the PVC showing as "Bound" when the PV isn't fully ready yet.

Potential fix: https://github.com/openshift/online/pull/127

Comment 3 Abhishek Gupta 2016-05-09 11:21:44 UTC
The mentioned PR is merged - is this bug resolved?

Comment 4 Mark Turansky 2016-05-10 14:36:01 UTC
Abhishek, yes the PR is merged and bug fixed.  A redeploy will fix it.

Comment 5 Vu Dinh 2016-05-10 14:41:30 UTC
*** Bug 1334011 has been marked as a duplicate of this bug. ***

Comment 6 Stefanie Forrester 2016-05-10 15:20:59 UTC
I have pulled the latest image onto dev-preview-int and re-deployed the online-volume-provisioner.

Comment 7 Chao Yang 2016-05-11 03:20:56 UTC
Verification is passed in online env
1. oc new-app jenkins-persistent
2. check pvc
jenkins   Bound     pv-aws-fvdfk   1Gi        RWO           19m
3. check pod 
NAME              READY     STATUS    RESTARTS   AGE
jenkins-1-ahtj9   1/1       Running   1          21m


Note You need to log in before you can comment on or make changes to this bug.