Bug 1333141 - [RFE] Packaging Barbican for OSP (fully supported) [NEEDINFO]
Summary: [RFE] Packaging Barbican for OSP (fully supported)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-barbican
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ade Lee
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
: 1403917 (view as bug list)
Depends On:
Blocks: 1419948 ciscoosp13features, ciscoosp13rfe 1434225 1465537 1305024 1365571 1403917 1412823 1419556
TreeView+ depends on / blocked
 
Reported: 2016-05-04 18:39 UTC by Maxime Payant-Chartier
Modified: 2020-08-13 08:28 UTC (History)
32 users (show)

Fixed In Version: openstack-barbican-6.0.0-0.20180123051321.3d3ea33.el7ost python-barbican-tests-tempest-0.0.1-0.20180122200349.5db05b8.el7ost puppet-barbican-12.2.0-0.20180119081204.eef142e.el7ost python-castellan-0.17.0-0.20180118222347.8e2929b.el7ost
Doc Type: Enhancement
Doc Text:
Cause: Consequence: Fix: Result:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:26:26 UTC
Target Upstream Version:
knylande: needinfo? (alee)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 11725 None rpm-master: MERGED openstack/tempest-distgit: Add barbican-tempest-plugin to -all subpackage (I891bcd7a338120f5866fd0a677ea25702a3d262c) 2018-02-07 14:05:54 UTC
Red Hat Knowledge Base (Solution) 2544661 None None None 2017-09-07 10:00:34 UTC
Red Hat Product Errata RHEA-2018:2086 normal SHIPPED_LIVE Red Hat OpenStack Platform 13.0 Enhancement Advisory 2018-06-28 19:51:39 UTC

Description Maxime Payant-Chartier 2016-05-04 18:39:37 UTC
Description of problem:

Multiple use cases require Barbican currently. Octavia project needs Barbican in order to move forward, Cisco needs it for managing disk encryption keys (which is required for secure deployment of OpenStack).


Have barbican packaged into RDO and added to delorean is necessary to support all of these use cases and address certain security concerns within OpenStack.

Comment 12 Nathan Kinder 2017-03-17 17:50:46 UTC
*** Bug 1403917 has been marked as a duplicate of this bug. ***

Comment 36 Jon Schlueter 2018-02-01 19:43:28 UTC
Following RPMs are available in 13 so far:

openstack-barbican-6.0.0-0.20180123051321.3d3ea33.el7ost
python-barbican-tests-tempest-0.0.1-0.20180122200349.5db05b8.el7ost
puppet-barbican-12.2.0-0.20180119081204.eef142e.el7ost
python-castellan-0.17.0-0.20180118222347.8e2929b.el7ost
python-barbicanclient-4.5.2-0.20171003135933.714fce2.el7ost

The following container images are also available:

openstack-barbican-base-docker-13.0-4
openstack-barbican-api-docker-13.0-2
openstack-barbican-keystone-listener-docker-13.0-3
openstack-barbican-worker-docker-13.0-2

Please review if any other moving pieces are needed to move this to MODIFIED

Comment 37 Ade Lee 2018-02-01 21:36:35 UTC
LGTM

Comment 40 Prasanth Anbalagan 2018-03-20 23:47:14 UTC
(overcloud) [stack@undercloud-0 testrun1]$ tempest run --regex test_volume_encryption
{0} barbican_tempest_plugin.tests.scenario.test_volume_encryption.VolumeEncryptionTest.test_encrypted_cinder_volumes_cryptsetup [87.735962s] ... ok
{0} barbican_tempest_plugin.tests.scenario.test_volume_encryption.VolumeEncryptionTest.test_encrypted_cinder_volumes_luks [69.108078s] ... ok

======
Totals
======
Ran: 2 tests in 187.0000 sec.
 - Passed: 2
 - Skipped: 0
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 156.8440 sec.

Comment 41 Prasanth Anbalagan 2018-03-21 02:05:10 UTC
(overcloud) [stack@undercloud-0 testrun1]$ tempest run --regex test_ephemeral_disk_encryption
{0} barbican_tempest_plugin.tests.scenario.test_ephemeral_disk_encryption.EphemeralStorageEncryptionTest.test_encrypted_ephemeral_lvm_storage [55.038254s] ... ok

======
Totals
======
Ran: 1 tests in 84.0000 sec.
 - Passed: 1
 - Skipped: 0
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 55.0383 sec.

Comment 42 Prasanth Anbalagan 2018-03-21 21:29:15 UTC
[stack@undercloud-0 testrun1]$ tempest run --regex test_image_signing
{0} barbican_tempest_plugin.tests.scenario.test_image_signing.ImageSigningTest.test_signed_image_upload_and_boot [29.944981s] ... ok
{0} barbican_tempest_plugin.tests.scenario.test_image_signing.ImageSigningTest.test_signed_image_upload_boot_failure [12.585326s] ... ok

======
Totals
======
Ran: 2 tests in 72.0000 sec.
 - Passed: 2
 - Skipped: 0
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 42.5303 sec.

Comment 46 errata-xmlrpc 2018-06-27 13:26:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.