Bug 1333189 - [lazy sync] pulp - catalog entries not created for pre-existing units
Summary: [lazy sync] pulp - catalog entries not created for pre-existing units
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-04 21:40 UTC by Tom McKay
Modified: 2019-09-26 14:37 UTC (History)
14 users (show)

Fixed In Version: pulp-rpm-2.8.7.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-26 12:26:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 1897 High CLOSED - CURRENTRELEASE catalog entries not created for pre-existing units 2016-06-27 17:00:45 UTC
Red Hat Product Errata RHBA-2016:2108 normal SHIPPED_LIVE Satellite 6.2.3 Async Bug Release 2016-10-26 16:21:52 UTC

Description Tom McKay 2016-05-04 21:40:30 UTC
When syncing a repo with download policy of on_demand, if it associates units to the repo that were already in pulp's DB, the sync does not create catalog entries. It should create catalog entries at least for any units where downloaded=False.

To reproduce:

    create a repo with on_demand and sync it
    see catalog entries for those units in the DB
    delete the repo
    see there are no catalog entries for those units in the DB
    re-create the same repo with on_demand and sync it
    see that there are no catalog entries for those units in the DB

Comment 2 pulp-infra@redhat.com 2016-05-12 13:30:43 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 3 pulp-infra@redhat.com 2016-05-12 13:30:45 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 4 pulp-infra@redhat.com 2016-05-13 15:00:37 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 5 pulp-infra@redhat.com 2016-05-19 14:00:21 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 8 pulp-infra@redhat.com 2016-06-02 19:30:27 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 9 pulp-infra@redhat.com 2016-06-08 20:30:26 UTC
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.

Comment 11 pulp-infra@redhat.com 2016-06-27 17:00:47 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 12 Brad Buckingham 2016-07-25 13:21:02 UTC
Moving to POST as upstream fix is available.

Comment 15 Kedar Bidarkar 2016-10-18 15:02:55 UTC
1) Created a repo with on_demand download_policy 
2) saw catalog entries for those units in the DB
Below are the commands to view the catalog entries.
a) mongo pulp_database
b) db.lazy_content_catalog.find()
3) deleted the repo
4) saw there are no catalog entries for those units in the DB
5) re-created the same repo with on_demand and synced it
6) we can again view the catalog entries for those units in the DB


VERIFIED With sat623-snap2

Comment 16 Jeff Ortel 2016-10-24 14:33:22 UTC
The steps listed in #15 look good.

Comment 18 errata-xmlrpc 2016-10-26 12:26:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108


Note You need to log in before you can comment on or make changes to this bug.