Bug 13332 - RFE: text & gui options differ for nameserve
RFE: text & gui options differ for nameserve
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-02 15:39 EDT by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-13 12:08:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2000-07-02 15:39:15 EDT
The options for text versus gui install offer different options for
specifying nameservers.  The text option only offers specifying the primary
nameserver.  The gui option allows specifying the primary as well as two
additional nameservers.  Pick one, be consistent.
Comment 1 Michael Fulbright 2000-07-05 13:00:00 EDT
Screens are current frozen so we cannot change now - will put this on the
feature request list for the next release.
Comment 2 Brent Fox 2000-09-23 12:28:53 EDT
There are additional issues related to this.  I think that the labels need to be
consistent as well.  Why does the text mode say 'nameserver' when GUI mode says
'DNS'?  Also, the GUI mode lets you set addresses for the Broadcast and Network
settings, but the text mode does not.  Also, GUI mode lets you decide if you
want the network to start on boot-up with the 'Activate on boot' checkbox, which
the text mode lacks.  

Dr. Mike, do you have any opinions about which mode should be changed?

Brent
Comment 3 Brent Fox 2000-11-07 14:26:43 EST
I've changed the python module in the text mode installer to ask for secondary
and ternary nameservers.  I haven't changed the one in the loader because that
one is written in C and would require much more work to fix.

Brock, please verify that the python version works now.  I've tested it myself
with positive results.
Comment 4 Brock Organ 2000-12-04 16:00:03 EST
this is not consistent across all cases ... for example, using bootnet.img for a
text mode install does not ask for secondary or ternary nameserver (either in
stage one or stage two) ...
Comment 5 Brock Organ 2000-12-13 12:08:43 EST
verified fix using qa1213.0 test tree ...

Note You need to log in before you can comment on or make changes to this bug.