Bug 1333210 - calarmari-ctl initialize failure on upgraded ceph cluster
Summary: calarmari-ctl initialize failure on upgraded ceph cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Christina Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-04 23:58 UTC by Warren
Modified: 2016-08-23 19:37 UTC (History)
4 users (show)

Fixed In Version: RHEL: calamari-server-1.4.0-0.9.rc12.el7cp Ubuntu: calamari-server_1.4.0~rc12-2redhat1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:37:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
contents of temp file (3.00 KB, text/plain)
2016-05-04 23:58 UTC, Warren
no flags Details
netstat -ltn results (2.81 KB, text/plain)
2016-05-10 21:00 UTC, Warren
no flags Details
salt-call output (2.35 KB, text/plain)
2016-05-10 21:02 UTC, Warren
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Warren 2016-05-04 23:58:49 UTC
Created attachment 1154032 [details]
contents of temp file

Description of problem:

Installed a 1.3.2 ceph cluster.  Upgraded to 2.0.  Ceph health show HEALTH_OK

Ran the steps in section 3.1.1 of:
https://access.qa.redhat.com/documentation/en/red-hat-ceph-storage/version-2/installation-guide-for-red-hat-enterprise-linux/#enabling_ceph_repositories

I am trying to be able to import this cluster to a running rhc instance.

When I get to step 10, I get the following message when running calamari-ctl initialize:
    
[INFO] Loading configuration..
[ERROR] We are sorry, an unexpected error occurred.  Debugging information has
been written to a file at '/tmp/2016-05-04_2332.txt', please include this when seeking technical
support.

I have attached the output.  It looks like we may be using the wrong TCP port.

How reproducible:

1 out of 1 times


Additional info:

See attached file.

Comment 2 Christina Meno 2016-05-09 18:14:39 UTC
Warren what this error is saying is calamari wants to do some stuff with postgres but postgres doesn't seem to be running.

The info I'd like to see if you still have access to the env is 
netstat -ltn

and then the output of 
sudo salt-call --local state.template /opt/calamari/salt-local/postgres.sls

Comment 3 Warren 2016-05-10 21:00:00 UTC
Created attachment 1155878 [details]
netstat -ltn results

Netstat -ltn results

Comment 4 Warren 2016-05-10 21:02:04 UTC
Created attachment 1155879 [details]
salt-call output

 sudo salt-call --local state.template /opt/calamari/salt-local/postgres.sls

I believe that this is the same machine that I reported the problems on.  I do not think that there has been much done on this system in the meantime

Comment 5 Christina Meno 2016-05-19 17:11:41 UTC
I know what the fix is here. It might take me some time to test it.
I'm not sure if I'll have this done by May20th

Comment 6 Alfredo Deza 2016-05-20 15:16:59 UTC
PR opened: https://github.com/ceph/calamari/pull/449

Warren: do you think you can try that change and see how that works for you?

Comment 7 Alfredo Deza 2016-05-20 15:31:38 UTC
re-targeted PR to 1.4 https://github.com/ceph/calamari/pull/450

Comment 8 Ken Dreyer (Red Hat) 2016-05-20 16:12:06 UTC
change will be in 1.4.0rc12 of calamari upstream.

Comment 10 Warren 2016-05-20 22:36:19 UTC
looks good

Comment 12 errata-xmlrpc 2016-08-23 19:37:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.