Bug 1333219 - view_subscription filter does not allow subscriptions to be viewed
Summary: view_subscription filter does not allow subscriptions to be viewed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.2.0
Hardware: x86_64
OS: Linux
high
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL:
Whiteboard:
: 1382031 1391374 1393065 1395668 1414912 1421816 (view as bug list)
Depends On:
Blocks: 1316897 1417082
TreeView+ depends on / blocked
 
Reported: 2016-05-05 01:12 UTC by Geoff Gatward
Modified: 2020-08-13 08:28 UTC (History)
28 users (show)

Fixed In Version: rubygem-katello-3.0.0.98-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1417082 (view as bug list)
Environment:
Last Closed: 2017-03-06 08:26:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 17054 0 Normal Closed view_subscription filter does not allow non-admin user to list/view the subscriptions. 2020-02-20 19:01:17 UTC
Red Hat Product Errata RHBA-2017:0447 0 normal SHIPPED_LIVE Satellite 6.2.8 Async Bug Release 2017-03-06 13:23:41 UTC

Description Geoff Gatward 2016-05-05 01:12:23 UTC
Description of problem:
Any non-administrator user role with the view_subscription filter included cannot actually view subscriptions.

Version-Release number of selected component (if applicable):
Satellite 6.2.0 Beta 1 (RHEL7)

How reproducible:
100%

Steps to Reproduce:
1. Create user role with Organization --> view_subscriptions 
2. Assign role to non-admin user
3. Login as that user
4. Navigate to Content --> Red Hat Subscriptions

Actual results:
"We're sorry, something went wrong"

Expected results:
Subscriptions are able to be viewed

Additional info:
Can also be reproduced with default 'Viewer' role. All other menus appear to work except for this function.

Comment 3 Brad Buckingham 2016-10-25 14:50:32 UTC
Upstream Katello PR: https://github.com/Katello/katello/pull/6408

Comment 4 Brad Buckingham 2016-11-07 20:39:27 UTC
Increasing the priority as this was also requested by bug 1391374.

Comment 5 Brad Buckingham 2016-11-07 20:39:34 UTC
*** Bug 1391374 has been marked as a duplicate of this bug. ***

Comment 6 Marek Hulan 2016-11-09 10:05:03 UTC
*** Bug 1393065 has been marked as a duplicate of this bug. ***

Comment 8 David Kaylor 2016-11-10 14:17:48 UTC
Another way to reproduce this issue:

1. Create a role with all Activation Key permissions
2. Assign this role (and any others) to a user
3. Create an activation key with the user to show that create/edit perms are working. Attach some subscriptions to the key.


Actual results:

View the Subscriptions tab of the key and see the following message:

You currently don't have any Subscriptions associated with this Activation Key, you can add Subscriptions after selecting the 'Add' tab. 


Expected results:

A list of subscriptions that the user can edit

Comment 9 Marek Hulan 2016-11-16 13:29:31 UTC
*** Bug 1395668 has been marked as a duplicate of this bug. ***

Comment 10 Marek Hulan 2016-11-22 09:33:11 UTC
*** Bug 1382031 has been marked as a duplicate of this bug. ***

Comment 25 Konstantin Trufanov 2017-02-10 08:46:06 UTC
*** Bug 1414912 has been marked as a duplicate of this bug. ***

Comment 26 Marek Hulan 2017-02-14 08:19:27 UTC
*** Bug 1421816 has been marked as a duplicate of this bug. ***

Comment 28 Sagar Lutade 2017-02-15 12:55:34 UTC
*** Bug 1421816 has been marked as a duplicate of this bug. ***

Comment 29 jcallaha 2017-02-15 20:36:10 UTC
Verified in Satellite 6.2.8 Snap 2

I created a new user with only permission to view subscriptions. After logging into that user, i was able to successfully view the subscriptions page. See attached screenshot. I was also able to see the subscriptions listed in an activation key, after adding the activation key permissions.

Bonus: I then removed the subscription viewer permission and went back to the activation key. I was able to see the key, but the subscriptions never loaded (403 in concole).

Comment 31 Lukas Zapletal 2017-02-20 09:02:17 UTC
Instead calling foreman-installer --upgrade I recommend to run faster and safer command:

foreman-rake db:migrate

Comment 35 errata-xmlrpc 2017-03-06 08:26:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0447


Note You need to log in before you can comment on or make changes to this bug.