Bug 1333263 - [features/worm] Unwind FOPs with op_errno and add gf_worm prefix to functions
Summary: [features/worm] Unwind FOPs with op_errno and add gf_worm prefix to functions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1341556
TreeView+ depends on / blocked
 
Reported: 2016-05-05 07:10 UTC by Karthik U S
Modified: 2017-03-27 18:15 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1341556 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:15:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Karthik U S 2016-05-05 07:10:23 UTC
Description of problem:

1.In the worm translator the FOPs are being unwinded using the errno -1. This should be replaced with the op_errno and assigning the proper error numbers to that.
2.Some of the functions in worm-helper.c should have gf_worm prefix so that they will not clash with any other functions.
The functions in worm.c should be static.

Version-Release number of selected component (if applicable):
Glsuterfs3.8.0




Additional info:
Requesting for review.

Comment 1 Vijay Bellur 2016-05-05 07:18:01 UTC
REVIEW: http://review.gluster.org/14222 (unwinding FOPs with op_errno. Added gf_worm prefix to functions in worm-helper.c and made the functions static in worm.c.) posted (#1) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 2 Vijay Bellur 2016-05-12 07:17:28 UTC
REVIEW: http://review.gluster.org/14222 (features/worm: updating function names & unwinding FOPs with op_errno) posted (#2) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 3 Vijay Bellur 2016-05-25 10:55:21 UTC
REVIEW: http://review.gluster.org/14222 (features/worm: updating function names & unwinding FOPs with op_errno) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 4 Vijay Bellur 2016-05-26 08:28:10 UTC
REVIEW: http://review.gluster.org/14222 (features/worm: updating function names & unwinding FOPs with op_errno) posted (#4) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 5 Vijay Bellur 2016-05-26 18:53:20 UTC
REVIEW: http://review.gluster.org/14222 (features/worm: updating function names & unwinding FOPs with op_errno) posted (#5) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 6 Vijay Bellur 2016-05-27 12:16:33 UTC
REVIEW: http://review.gluster.org/14222 (features/worm: updating function names & unwinding FOPs with op_errno) posted (#6) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 7 Vijay Bellur 2016-05-30 13:29:20 UTC
REVIEW: http://review.gluster.org/14222 (features/worm: updating function names & unwinding FOPs with op_errno) posted (#7) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 8 Vijay Bellur 2016-05-31 15:56:00 UTC
COMMIT: http://review.gluster.org/14222 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 03880f81dad9fd2a3a07c56a3cfbb994d44819b7
Author: karthik-us <ksubrahm@redhat.com>
Date:   Thu May 5 12:42:35 2016 +0530

    features/worm: updating function names & unwinding FOPs with op_errno
    
    - Added gf_worm prefix to some of the functions in worm-helper files so that
      they do not clash with other functions
    - Made the functions in worm.c static
    - Unwinding the FOPs with op_errno instead of using different unwind statements
    - Removed the multiple goto labels (wind & unwind)
    
    Change-Id: I3a2f114061aae4b422df54e91c4b3f702af5d0b0
    BUG: 1333263
    Signed-off-by: karthik-us <ksubrahm@redhat.com>
    Reviewed-on: http://review.gluster.org/14222
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 9 Shyamsundar 2017-03-27 18:15:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.