Bug 133337 - Upgrade installation does not install grub, leaves system unbootable
Summary: Upgrade installation does not install grub, leaves system unbootable
Status: CLOSED DUPLICATE of bug 132878
Alias: None
Product: Fedora
Classification: Fedora
Component: grub   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-09-23 09:28 UTC by Adam Wiggins
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Wiggins 2004-09-23 09:28:27 UTC
Upgrading FC2 -> FC3t3 using CDs.  All defaults chosen through install wizard.  Entire 
install completes, and then after reboot the FC2 grub screen appears - apparently the FC3 
upgrade did not overwrite the old grub boot sector.  When pressing enter on the choice 
listed it produces "file not found" (not shocking since it is referring to the FC2 kernel).

I tried going into rescue mode and modifying grub.conf to point to the correct file, but this 
resulted in a boot that just printed "GRUB" and then locked.  I then tried rerunning grub-
install but the result was almost the same: rebooting produced "GRUB" being printed 
infinitely across the screen.

Comment 1 Jeremy Katz 2004-09-23 15:40:50 UTC
Can you boot into rescue mode and grab the /root/upgrade.log and see
if there are any errors/warnings in there?

Comment 2 Adam Wiggins 2004-09-24 03:25:35 UTC
I already did a fresh reinstall which wiped the / partition.  I may 
try upgrading another system soon, if it happens there I will be sure 
to grab the log.  Sorry about that... 
 

Comment 3 Jeremy Katz 2004-09-24 21:26:38 UTC

*** This bug has been marked as a duplicate of 132878 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:05:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.