Bug 1333392 - 'net -k ads join' fails
Summary: 'net -k ads join' fails
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 23
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2016-05-05 12:13 UTC by David Woodhouse
Modified: 2016-12-20 20:22 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2016-12-20 20:22:09 UTC
Type: Bug

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Samba Project 11903 0 None None None 2016-05-05 12:16:18 UTC

Description David Woodhouse 2016-05-05 12:13:40 UTC
# dnf downgrade samba\* libwbclient\* libsmbclient\* ctdb\*
(to 4.3.0, although 4.3.6 also worked)
# net -k ads join GER.CORP.INTEL.COMldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory
Kinit for DWOODHOU-DESK7$ to access cifs/HASGER402.ger.corp.intel.com.INTEL.COM failed: Preauthentication failed
Using short domain name -- GER
Joined 'DWOODHOU-DESK7' to dns domain 'ger.corp.intel.com'
kerberos_kinit_password DWOODHOU-DESK7$@GER.CORP.INTEL.COM failed: Preauthentication failed
DNS update failed: kinit failed: Preauthentication failed
[root@dwoodhou-desk7 ~]# echo $?

... Noisy (and often prompts users to complain), but it worked.

# dnf update
(to 4.3.8)
# net -k ads join GER.CORP.INTEL.COM
ldb: unable to stat module /usr/lib64/samba/ldb : No such file or directory
Kinit for DWOODHOU-DESK7$ to access cifs/HASGER402.ger.corp.intel.com.INTEL.COM failed: Preauthentication failed
Failed to join domain: failed to verify domain membership after joining: Logon failure

I can provide -d10 output from both on request.

Comment 1 Fedora End Of Life 2016-11-25 08:57:27 UTC
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 2 Fedora End Of Life 2016-12-20 20:22:09 UTC
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.