Bug 1333492 - multipath reports successful resize of math on second attempt
Summary: multipath reports successful resize of math on second attempt
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath   
(Show other bugs)
Version: 7.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
Steven J. Levine
URL:
Whiteboard:
Keywords:
Depends On: 1328077
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-05 15:57 UTC by Ben Marzinski
Modified: 2016-11-04 08:19 UTC (History)
11 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-91.el7
Doc Type: Bug Fix
Doc Text:
Multiple calls to resize a device will each attempt to resize the device, and will correctly report the result Previously, if `multipathd` failed to resize a device, it continued to think that the device had the new size. Subsequent calls to resize the device would report success and not resize the device because `multipathd` thought that it had nothing left to do. With this fix, `multipathd` now resets the device size to the original size if the resize fails. As a result, multiple calls to resize a device will each attempt to resize the device, and will correctly report the result.
Story Points: ---
Clone Of: 1328077
Environment:
Last Closed: 2016-11-04 08:19:25 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2536 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2016-11-03 14:18:10 UTC

Comment 2 Ben Marzinski 2016-06-03 18:44:46 UTC
When multipath failed the resize, it was still thinking it had the larger size internally.  Thus, when the second resize command happened, it through that it had nothing to do, and returned success. I've made it reset it's size internally, when the resize command fails.

Comment 11 errata-xmlrpc 2016-11-04 08:19:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html


Note You need to log in before you can comment on or make changes to this bug.