Bug 133351 - firstboot didn't run
firstboot didn't run
Status: CLOSED DUPLICATE of bug 132736
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-23 09:43 EDT by Alexander Larsson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Larsson 2004-09-23 09:43:36 EDT
I just did a workstation install of rawhide-20040923, and I didn't get
firstboot during the first boot.
Comment 1 Alexander Larsson 2004-09-23 09:46:30 EDT
It worked fine when i ran it manually from the console as root.
Comment 2 Alexander Larsson 2004-09-23 09:47:11 EDT
This is pretty bad, as it means you can't change the resolution from
800x600, nor create a user.
Comment 3 Alexander Larsson 2004-09-23 09:54:12 EDT
Looking in /var/log/messages there is a line:
firstboot:  failed

nothing more.
Comment 4 Adrian Likins 2004-09-23 18:09:06 EDT
cc'ing DV, since I think this might be related to #132736
)

(patch for which, is in 1.3.26, if thats the issue)
Comment 5 Daniel Veillard 2004-09-23 18:16:27 EDT
What version of rhgb, firstboot and initscripts were used ?
Do you have a /etc/sysconfig/firstboot file ?
is firstboot listed in chkconfig --list firstboot ?
Is firstboot fails to start if you reboot again ?

Daniel
Comment 6 Alexander Larsson 2004-09-24 02:57:36 EDT
As I said, I used the ones in rawhide-20040923, ie:
rhgb-0.13.2-1
firstboot-1.3.25-1
initscripts-7.84-1

/etc/sysconfig/firstboot says
RUN_FIRSTBOOT=NO
but that is after i ran firstboot manually...

chkconfig --list firstboot gives:
service firstboot supports chkconfig, but is not referenced in any
runlevel (run 'chkconfig --add firstboot')

After the initial install i rebooted, and firstboot didn't run. 
Then i ran firstboot manually from the console.
Comment 7 Daniel Veillard 2004-09-24 04:31:30 EDT
firstboot-1.3.25-1 ? then it's normal, you need 1.3.26 to work with
rhgb-0.13.2 , issue raised in 132736,

Daniel

*** This bug has been marked as a duplicate of 132736 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:05:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.