Bug 1333586 - Windows doesn't like gparted's ntfs format
Summary: Windows doesn't like gparted's ntfs format
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gparted
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-05 22:12 UTC by Todd
Modified: 2016-11-19 21:07 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-10 03:29:24 UTC


Attachments (Terms of Use)
gparted looking a a perfectly mounted ntfs drive (40.94 KB, image/png)
2016-05-07 01:18 UTC, Todd
no flags Details

Description Todd 2016-05-05 22:12:55 UTC
Hi All,

    FC23 and Scientific Linux 7.2

    When I partition and format a drive with gparted in NTFS format, Linux can read it perfectly, but when I insert it into a Windows machine, Windows thinks it is unformatted  But, if I format it in Windows, it reads perfectly in both operating systems.

    Please fix.

Many thanks,
-T

Comment 1 Todd 2016-05-07 01:15:18 UTC
If it helps, this flash drive was formatted on Windows 7 Pro x64 SP1 to NTFS.  It works perfectly in W7, FC23 x64, and SL 7.2 x64.

This is from SL 7.2

# fdisk -l /dev/sdc

Disk /dev/sdc: 31.6 GB, 31625052160 bytes, 61767680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x6e697373

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   ?  1936269394  3772285809   918008208   4f  QNX4.x 3rd part
/dev/sdc2   ?  1917848077  2462285169   272218546+  73  Unknown
/dev/sdc3   ?  1818575915  2362751050   272087568   2b  Unknown
/dev/sdc4   ?  2844524554  2844579527       27487   61  SpeedStor

Partition table entries are not in disk order


I will upload a screenshot from gparted.  (By the way, it is mounted, regardless of what gparted says.)

-T

Comment 2 Todd 2016-05-07 01:18 UTC
Created attachment 1154771 [details]
gparted looking a a perfectly mounted ntfs drive

regardless of what the screen shot says, this drive (/dev/sdc1) is mounted and operating perfectly

Comment 3 Todd 2016-05-08 00:41:47 UTC
FC23 was 0.23
SL7 was 0.19

Comment 4 Mike Fleetwood 2016-05-08 11:10:17 UTC
The screen shot in comment 2 shows the Information about /dev/sdc1
dialog which includes this warning:
    The device /dev/sdc1 doesn't exist

    Unable to read the contents of this file system!
    Because of this some operations may be unavailable.
    The cause might be a missing software package.
    The following list of software packages is required for ntfs
    file system support: ntfsprogs / ntfs-3g.

For some reason GParted isn't able to read the usage of the file system.
Hence only a size figure in the top right, rather than used and unused
too.  Please provide the following information so I can try to work out
what is happening:

Output from the following commands:
    cat /proc/partitions
    ls -l /dev/sdc*
    rpm -qa | fgrep ntfs
    parted /dev/sdc print
    blkid | grep sdc
    df
    grep ntfs /proc/mounts
    ntfsresize --info --force --no-progress-bar /dev/sdc1

Screen shot in GParted of View > File System Support showing the ntfs
line.

Thanks,
Mike Fleetwood (GParted Developer)

Comment 5 Todd 2016-05-13 16:31:56 UTC
Hi All,

I upgrade gparted to 0.26 on FC24 Beta.  0.26 changed the partition ID over from 4F to 7.  And now Windows 7 is happy.  So corrected in 0.26.

Thank you!


# rpm -qa gparted
gparted-0.26.0-3.fc24.x86_64

# fdisk -l /dev/sdc
Disk /dev/sdc: 122 MiB, 127926272 bytes, 249856 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x9f59628e

Device     Boot Start    End Sectors  Size Id Type
/dev/sdc1        2048 249855  247808  121M  7 HPFS/NTFS/exFAT *

Comment 6 Todd 2016-05-20 15:50:23 UTC
Next release of what?   gparted 0.27?

Also, I partitioned and formatted a 350 GB drive with gparted 0.26 for NTFS and Windows coughed on it again.  Apparently my test of 0.26 on a 128 MB flash drive was flawed.  As soon as I got some modern size to the test drive: cough.

Comment 7 Mukundan Ragavan 2016-05-21 14:55:56 UTC
(In reply to Todd from comment #6)
> Next release of what?   gparted 0.27?
> 
> Also, I partitioned and formatted a 350 GB drive with gparted 0.26 for NTFS
> and Windows coughed on it again.  Apparently my test of 0.26 on a 128 MB
> flash drive was flawed.  As soon as I got some modern size to the test
> drive: cough.

Todd, you closed the bug as nextrelease! :)

I will try to reproduce this. So far, I have been unsuccesful ... :(

Comment 8 Todd 2016-05-22 07:08:12 UTC
(In reply to Mukundan Ragavan from comment #7)
> (In reply to Todd from comment #6)
> > Next release of what?   gparted 0.27?
> > 
> > Also, I partitioned and formatted a 350 GB drive with gparted 0.26 for NTFS
> > and Windows coughed on it again.  Apparently my test of 0.26 on a 128 MB
> > flash drive was flawed.  As soon as I got some modern size to the test
> > drive: cough.
> 
> Todd, you closed the bug as nextrelease! :)

You kids get off my lawn !!!   I have a lawn ???  :'[
 
> I will try to reproduce this. So far, I have been unsuccesful ... :(

This is what I did:

1) Got a 32 GB or larger drive I didn't mind wiping out.

2) erased the front of the drive with
       dd bs=4096  if=/dev/zero  of=/dev/sdc  count=1000

3) fired up gparted (pressing the green arrow to commit)
    --> Device, Create Partition table, msdos
      -->  Partition, New, 1 primary, ntfs
        --> Partition, Format,  ntfs

4) go find a Windows 7 computer and try it out.

Comment 9 Mukundan Ragavan 2016-05-22 21:21:10 UTC
Thanks for posting the steps. 

I do not have a windows system at the moment. I will try it out tomorrow.

Comment 10 Todd 2016-05-22 22:50:59 UTC
(In reply to Mukundan Ragavan from comment #9)
> Thanks for posting the steps. 
> 
> I do not have a windows system at the moment. I will try it out tomorrow.

I have a G-technology G-Drive EV coming for a customer with Windows 7 Pro x64:
http://www.g-technology.com/products/g-drive-ev

I like to boot into my Xfce direct install flash drive and use "gdisk" to remove the weird OSx GPT partitioning.  (Wish gparted did that too. I will do an RFE for that some time soon).  I have gparted 0.26 on that flash drive too, so I will attempt to ntfs it and report back.

Comment 11 Todd 2016-05-22 23:11:33 UTC
When you get to the Windows machine, go into disk manager to look and see what you got:

--> <win><R>
  --> Diskmgmt.msc

Going back to Linux, if you erase the first part of the disk with dd (see my steps), you can go back into Windows Diskmgmt.msc again, partition and format for ntfs, then bring it back to Linux gparted and see the difference.

You would think you could redo the disk with Diskmgmt.msc, but it won't have any part of it, so back to Linux and dd.

You may want to have a Live DVD/USB handy.  On a Live USB, do a "dnf upgrade gparted" to get to gparted 0.26

Comment 12 Fedora Update System 2016-11-02 01:12:28 UTC
gparted-0.27.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9110e35304

Comment 13 Fedora Update System 2016-11-02 01:12:39 UTC
gparted-0.27.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-be8f7cacce

Comment 14 Geoffrey Marr 2016-11-02 02:32:53 UTC
Used gparted-0.27.0-1.fc25 to write an "NTFS" formatted disk. Disk mounted fine in Windows XP SP3.

Comment 15 Fedora Update System 2016-11-02 14:52:43 UTC
gparted-0.27.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9110e35304

Comment 16 Mike Fleetwood 2016-11-03 20:36:06 UTC
Just documenting the likely causes of this bug report for the record
in case anybody stumbles across it.

Nothing has changed in how GParted formats NTFS in a long time.  Not
between GParted 0.23.0 originally included in Fedora 23 and
GParted 0.27.0.  It uses the mkntfs command from the ntfsprogs package.
https://git.gnome.org/browse/gparted/tree/NEWS?h=GPARTED_0_27_0

Either Todd had a local issue or possibly an update of the ntfsprogs
package fixed mkntfs.  Because of my analysis in comment 4 I lean
towards the former.

Comment 17 Mukundan Ragavan 2016-11-04 01:35:30 UTC
Thanks Mike.

Comment 18 Fedora Update System 2016-11-05 03:31:46 UTC
gparted-0.27.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-be8f7cacce

Comment 19 Fedora Update System 2016-11-10 03:29:24 UTC
gparted-0.27.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2016-11-19 21:07:57 UTC
gparted-0.27.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.