This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 13336 - RFE: More packages should be de-selectable
RFE: More packages should be de-selectable
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-02 19:05 EDT by Christian Rose
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-17 16:47:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2000-07-02 19:05:31 EDT
Everytime I install Red Hat, I get the packages

kernel-pcmcia-cs
apmd
raidtools

no matter what. I only have desktop systems and have no need for these
packages. They're just annoying extra packages (I try to keep my systems
as small as possible) that I have to remove manually after every
install/upgrade. 

I understand that these packages should probably be installed as default
since the two first ones are definately needed for laptops and the last
one for systems with software raid already set up.

But my vote is that these packages should be de-selectable at least if
one chooses a custom install.
Comment 1 Gene Czarcinski 2000-07-03 11:15:30 EDT
I concur
Comment 2 Jeremy Katz 2000-07-06 02:32:00 EDT
There's now a Laptop package in beta3 including apmd and kernel-pcmcia-cs (as
well as the irda and wireless tools), but raidtools are always installed by
default.  Also, these packages could be useful or necessary on a desktop system
(more are beginning to use wireless lan to interact with roaming laptops)
Comment 3 Christian Rose 2000-08-01 20:42:30 EDT
In Pinstripe, kernel-pcmcia-cs and apmd seem to be back in the base package, and
thus they get installed on all systems, whether essential or completely
unnecessary, and they're not de-selectable during a custom install.

:-(
Comment 4 Michael Fulbright 2000-08-17 16:47:48 EDT
This is required so a machine install with PCMCIA will reboot and networking
will work properly.

Note You need to log in before you can comment on or make changes to this bug.