Bug 133365 - autofs not unmounting
autofs not unmounting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 11:16 EDT by Neal Becker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 16:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2004-09-23 11:16:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
It appears that autofs is not timing out and unmounting like it used to.

Here is some more info, problem is /home/lchen, which was mounted yesterday, and doesn't seem to be unmounting.

mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/sda1 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid3115) on /net type autofs (rw,fd=5,pgrp=3115,minproto=2,maxproto=4)
automount(pid3148) on /user type autofs (rw,fd=5,pgrp=3148,minproto=2,maxproto=4)
automount(pid3192) on /home type autofs (rw,fd=5,pgrp=3192,minproto=2,maxproto=4)
nfsd on /proc/fs/nfsd type nfsd (rw)
/disk1/nbecker on /home/nbecker type none (rw,bind)
/dev/hda3 on /media/idedisk1 type ext3 (rw,nosuid,nodev)
exdata1:/disk3/users/lchen on /user/lchen type nfs (rw,nosuid,rsize=8192,wsize=8192,intr,hard,intr,addr=139.85.77.100)
/user/lchen on /home/lchen type none (rw,bind)
/dev/hdb2 on /media/idedisk type ext3 (rw,nosuid,nodev,user=nbecker)

Version-Release number of selected component (if applicable):
autofs-4.1.3-17

How reproducible:
Didn't try

Steps to Reproduce:
1. user logs in, home dir is automounted
2. user logs out, home dir is never unmounted
3.
    

Additional info:
Comment 1 Andy Green 2004-10-04 03:28:48 EDT
Me too - here is my post to Fedora-Test about it, I was just making a 
Bugzilla myself.... 
 
Just noticed on two machines tracking the Development branch, that 
autofs 
seems to be ignoring --timeout.  Eg: 
 
/etc/auto.master: 
 
/misc   /etc/auto.misc --timeout=2 
 
/etc/auto.misc: 
 
usbautocam 
-fstype=vfat,nosuid,nodev,sync,dirsync,uid=99,gid=99,umask=000 :/dev/sda1 
 
 
mount shows autofs running: 
 
... 
automount(pid6032) on /misc type autofs 
(rw,fd=4,pgrp=6032,minproto=2,maxproto=4) 
 
On device insertion, it is automounted: 
 
... 
automount(pid6032) on /misc type autofs 
(rw,fd=4,pgrp=6032,minproto=2,maxproto=4) 
/dev/sda1 on /misc/usbautocam type vfat 
(rw,nosuid,nodev,sync,dirsync,uid=99,gid=99,umask=000) 
 
 
However.... 
 
[root@fastcat ~]# lsof -n | grep /misc 
automount 6032       root    4r      DIR       
0,18        0      18246 /misc 
 
Okay so nothing is touching the mountpoint /misc/usbautocam.  Wait 
several 
seconds and do another mount command to see what is what.... 
 
... 
automount(pid6032) on /misc type autofs 
(rw,fd=4,pgrp=6032,minproto=2,maxproto=4) 
/dev/sda1 on /misc/usbautocam type vfat 
(rw,nosuid,nodev,sync,dirsync,uid=99,gid=99,umask=000) 
 
Previously the mountpoint would disappear after a couple of seconds, 
now it is 
immortal. 
 
[root@fastcat ~]# rpm -q autofs 
autofs-4.1.3-22 
 
Unmounting by hand works okay, and will allow reinsertion of the 
device, which 
is then automounted again.  But never auto-unmounted. 
 
Comment 2 Andy Green 2004-10-05 09:16:57 EDT
Can I offer any assistance with testing this serious problem? 
 
Has it been duplicated? 
 
Is the problem in autofs, or hotplug, or the kernel...??? 
 
Comment 3 Andy Green 2004-10-05 14:14:48 EDT
The problem is in autofs.  Downgrading to 
 
autofs-4.1.2-2 
 
from FC2 immediately and completely fixed the problem. 
 
 
Comment 4 Chris Feist 2004-10-18 17:13:36 EDT
This bug should be fixed in the latest development autofs package
(autofs-4.1.3-28.i386.rpm) you should be able to download it from here
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/autofs-4.1.3-28.i386.rpm

Comment 5 Neal Becker 2004-10-19 16:08:06 EDT
Confirmed!  Fixed in autofs-4.1.3-28. 

Note You need to log in before you can comment on or make changes to this bug.