Bug 133366 - missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-23 11:27 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 09:24:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-09-23 11:27:01 EDT
Description of problem:

[root@hoho2 lib]# yum install gnome-bluetooth

Error: missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
Error: missing dep: libopenobex-1.0.so.0 for pkg libbtctl

Version-Release number of selected component (if applicable):

  up2date

How reproducible:

  Has been a problem for the last few days

Steps to Reproduce:

1. rpm -e --nodeps <all the components affecting>
2.  yum clean all
3.  rpm --rebuilddb
4. yum update (have nothing to update message..)
4. yum install gnome-bluetooth

(not all of these steps may be necessary..)
  
Actual results:

[root@hoho2 lib]# yum install gnome-bluetooth
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3500/3500
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Fedora Core 2 - Development Tree
Resolving Dependencies
gnome-bluetooth-0.5.1-3.i 100% |=========================|  11 kB    00:00
Restarting Dependency Process with new changes
libbtctl-0.4.1-1.i386.rpm 100% |=========================| 8.0 kB    00:00
Error: missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
Error: missing dep: libopenobex-1.0.so.0 for pkg libbtctl


Expected results:

  Clean install

Additional info:
Comment 1 Bob Gustafson 2004-09-25 10:51:58 EDT
It looks like gnome-bluetooth just needs to be relinked with the
current libopenobex furnished by openobex. Yes?

[root@hoho2 user1]# yum install gnome-bluetooth
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3500/3500
Excluding Packages
Excluding Incompatible Archs
Finished
Excluding Packages from Fedora Core 2 - Development Tree
Resolving Dependencies
Restarting Dependency Process with new changes
Error: missing dep: libopenobex-1.0.so.0 for pkg gnome-bluetooth
Error: missing dep: libopenobex-1.0.so.0 for pkg libbtctl

[root@hoho2 user1]# ls -l /usr/lib/libopenobex*
lrwxrwxrwx  1 root root    24 Sep 23 07:45
/usr/lib/libopenobex-1.0.so.1 -> libopenobex-1.0.so.1.0.0
-rwxr-xr-x  1 root root 20720 Sep 13 09:47
/usr/lib/libopenobex-1.0.so.1.0.0

[root@hoho2 user1]# rpm -q openobex
openobex-1.0.1-1
[root@hoho2 user1]#

[root@hoho2 user1]# rpm -q --filesbypkg openobex | grep lib
openobex                  /usr/lib/libopenobex-1.0.so.1
openobex                  /usr/lib/libopenobex-1.0.so.1.0.0
[root@hoho2 user1]#
Comment 2 Bob Gustafson 2004-09-25 11:25:31 EDT
It is not quite as easy (relink against current libopenobex) as I
suggeted above.

I wound up rebuilding libbtctl, openobex, openobex-apps,
gnome-bluetooth. (Never did find openobex-devel).

gnome-bluetooth complained initially about a missing openobex-devel
and libbtctl version was not right.

I went into gnome-bluetooth.spec and silenced the objections:

BuildRequires: GConf2-devel >= 0:2.0 librsvg2-devel
#BuildRequires: libbtctl >= 0:0.4.1
#BuildRequires: gob2 openobex-devel perl
ExcludeArch: s390 s390x

gnome-bluetooth built and installed fine. Don't know whether it works
any differently from the version I was originally complaining about,
but at least I have the source and files to do a bit more if I have time.
Comment 3 Bob Gustafson 2004-09-29 09:24:22 EDT
yum install gnome-bluetooth - works for me now


[root@hoho2 SPECS]# rpm -q openobex-devel
openobex-devel-1.0.1-1
[root@hoho2 SPECS]# rpm -q openobex-apps
openobex-apps-1.0.0-6
[root@hoho2 SPECS]# rpm -q openobex
openobex-1.0.1-1
[root@hoho2 SPECS]# rpm -q gnome-bluetooth
gnome-bluetooth-0.5.1-4
[root@hoho2 SPECS]#


Note You need to log in before you can comment on or make changes to this bug.