Bug 133367 - Unable de burn CDs as a normal user
Unable de burn CDs as a normal user
Status: CLOSED DUPLICATE of bug 130576
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 11:29 EDT by Emmanuel Druon
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Druon 2004-09-23 11:29:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
When using k3b as a normal user, you can't burn a CD

Version-Release number of selected component (if applicable):
k3b-0.11.12-1

How reproducible:
Always

Steps to Reproduce:
1. login as a normal user
2. run k3b
3. the cd burner seems unable to burn CDs
    

Actual Results:  You can't burn a CD

Expected Results:  You can burn the CD

Additional info:

If you do the same procedure as root, you can do what you want.
Changing permissions on /dev/cdrom (or /dev/hdc in my case) doesn't
change a thing.

For information, I'm running a 2.6.8-1.521 kernel.
Comment 1 Harald Hoyer 2004-09-23 11:31:00 EDT
where did you get that kernel??
Comment 2 Emmanuel Druon 2004-09-23 11:38:24 EDT
From fedora, it's kernel package kernel-2.6.8-1.521.i686.rpm released
in the updates directory on August,19.

Comment 3 Harald Hoyer 2004-09-23 12:13:07 EDT
great! :( then I have to release fixed xcdroast/k3b/cdrtools/cdrdao
Comment 4 Emmanuel Druon 2004-09-23 15:23:26 EDT
I'd be very thankful when you do ;)
Comment 5 Emmanuel Druon 2004-09-30 15:03:24 EDT
I upgraded to the new versions of
xcdroast/k3b/cdrtools/cdrdao/dvd+rw... and the problem is still there
: as root I have access to my burner (pioneer 105 dvd burner) but not
as a normal user.
For information, I have reset the k3brc files to be sure there's
nothing left around.
Any idea ?
Comment 6 Harald Hoyer 2004-10-01 04:11:33 EDT
be sure to have /dev/cdrom symlinks
Comment 7 Harald Hoyer 2004-10-01 04:12:43 EDT

*** This bug has been marked as a duplicate of 130576 ***
Comment 8 Anand Buddhdev 2004-10-23 17:18:54 EDT
I have just tried to use k3b-0.11.14-0.FC2.2 under kernel-2.6.8-1.521
to burn a DVD-R as a non-root user. It failed. I saw Harald's comment
about having /dev/cdrom symlinks. What exactly does that mean? I have
the following on my system:

lrwxrwxrwx  1 root root 8 Aug  5 00:19 /dev/cdrom -> /dev/hdc
lrwxrwxrwx  1 root root 8 Oct 23 21:02 /dev/cdrom1 -> /dev/hdd
lrwxrwxrwx  1 root root 8 Oct 22 12:32 /dev/cdwriter -> /dev/hdd
lrwxrwxrwx  1 root root 8 Aug  5 01:13 /dev/dvd -> /dev/hdc
lrwxrwxrwx  1 root root 8 Aug  5 01:13 /dev/dvdwriter -> /dev/hdd

Has my blank DVD-R been damaged, or can I still use it?
Comment 9 Harald Hoyer 2004-10-25 05:15:37 EDT
Anand Buddhdev: this problem can only be fixed with a new kernel
Comment 10 Harald Hoyer 2004-10-25 05:17:55 EDT
see bug 130576
Comment 11 Red Hat Bugzilla 2006-02-21 14:05:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.