Bug 1333670 - Warning during lvm2 installation: user -. does not exist - using root
Summary: Warning during lvm2 installation: user -. does not exist - using root
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Rajnoha
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1256306
TreeView+ depends on / blocked
 
Reported: 2016-05-06 07:05 UTC by Martin Banas
Modified: 2017-02-09 08:56 UTC (History)
10 users (show)

Fixed In Version: lvm2-2.02.156-1.el7
Doc Type: No Doc Update
Doc Text:
Intra-release bug, no documentation needed.
Clone Of:
Environment:
Last Closed: 2016-11-04 04:20:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Martin Banas 2016-05-06 07:05:51 UTC
Description of problem:
When lvm2 package is installed during RHEL-7.3 installation using anaconda, following is printed in log files:
19:30:22,394 INFO packaging: 7:lvm2-2.02.152-2.el7.x86_64 (275/320)
19:30:22,394 INFO packaging: warning: user -. does not exist - using root

Version-Release number of selected component (if applicable):
RHEL-7.3-20160505.n.0
7:lvm2-2.02.152-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start RHEL-7.3-20160505.n.0 installation
2. Check packaging.log for warnings and errors
3.

Actual results:
19:30:22,394 INFO packaging: 7:lvm2-2.02.152-2.el7.x86_64 (275/320)
19:30:22,394 INFO packaging: warning: user -. does not exist - using root

Expected results:
No warning message like this

Additional info:

Comment 2 Peter Rajnoha 2016-05-06 08:54:28 UTC
Spec file fix, will get into next rebuild:

-%attr(755, -, -) %dir %{_sysconfdir}/lvm
+%dir %{_sysconfdir}/lvm

Comment 5 Roman Bednář 2016-07-08 09:34:14 UTC
Verified. No lvm user warning observed in packaging.log with latest build.


Tested with:
3.10.0-460.el7.x86_64

lvm2-2.02.160-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016
lvm2-libs-2.02.160-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016
lvm2-cluster-2.02.160-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016
device-mapper-1.02.130-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016
device-mapper-libs-1.02.130-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016
device-mapper-event-1.02.130-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016
device-mapper-event-libs-1.02.130-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016
device-mapper-persistent-data-0.6.2-0.1.rc8.el7    BUILT: Wed May  4 09:56:34 CEST 2016
cmirror-2.02.160-1.el7    BUILT: Wed Jul  6 18:16:47 CEST 2016

Comment 7 errata-xmlrpc 2016-11-04 04:20:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.