Bug 1333679 - lvm2-lockd-2.02.152-2.el7.x86_64 fails to install because of missing dependencies
Summary: lvm2-lockd-2.02.152-2.el7.x86_64 fails to install because of missing dependen...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: ---
Assignee: Peter Rajnoha
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1112660
TreeView+ depends on / blocked
 
Reported: 2016-05-06 07:16 UTC by Martin Banas
Modified: 2016-11-04 04:20 UTC (History)
16 users (show)

Fixed In Version: lvm2-2.02.156-1.el7
Doc Type: No Doc Update
Doc Text:
Intra-release bug, no documentation needed.
Clone Of:
Environment:
Last Closed: 2016-11-04 04:20:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Martin Banas 2016-05-06 07:16:29 UTC
Description of problem
Following package has missing dependencies:
package: 7:lvm2-lockd-2.02.152-2.el7.x86_64 from Optional
  unresolved deps: 
     dlm >= 0:3.99.1-1
     sanlock-lib >= 0:3.3.0-1

Version-Release number of selected component (if applicable):
RHEL-7.3-20160505.n.0
lvm2-lockd-2.02.152-2.el7.x86_64

Steps to Reproduce
Install lvm2-lockd-2.02.152-2.el7.x86_64 on RHEL-7.3-20160505.n.0

Actual Result:
package: 7:lvm2-lockd-2.02.152-2.el7.x86_64 from Optional
  unresolved deps: 
     dlm >= 0:3.99.1-1
     sanlock-lib >= 0:3.3.0-1

Expected Result:
Package lvm2-lockd-2.02.152-2.el7.x86_64 install successfully on RHEL-7.3-20160505.n.0

Comment 5 Peter Rajnoha 2016-06-06 14:33:34 UTC
OK, sorry, this is a bug in lvm2.spec file - it's supposed to require dlm-lib not dlm for the lvm2-lockd. The reason here is that dlm-lib is available on more variants than dlm so it's still possible to install lvm2-lockd. Then you choose the locking backend in the configuration (it can be sanlock or dlm). Of course, dlm backend will work only where dlm itself is available, not just dlm-lib.

I'll fix this so it has the proper dlm-lib requirement back instead of dlm.

Comment 6 Peter Rajnoha 2016-06-06 14:38:54 UTC
Just for the reference, the 7.2 bug where we already solved this: bug #1241393

Comment 10 Roman Bednář 2016-06-20 08:14:59 UTC
Verified. Dependencies of lvm2-lockd now resolve properly.

===============================
Resolving Dependencies
--> Running transaction check
---> Package lvm2-lockd.x86_64 7:2.02.156-1.el7 will be installed
--> Processing Dependency: dlm-lib >= 3.99.1-1 for package: 7:lvm2-lockd-2.02.156-1.el7.x86_64
--> Processing Dependency: libdlm_lt.so.3()(64bit) for package: 7:lvm2-lockd-2.02.156-1.el7.x86_64
--> Running transaction check
---> Package dlm-lib.x86_64 0:4.0.6-1.el7 will be installed
--> Finished Dependency Resolution

Comment 12 errata-xmlrpc 2016-11-04 04:20:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.