Bug 133372 - /dev/ircomm* devices are not available
Summary: /dev/ircomm* devices are not available
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: irda-utils   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-23 16:08 UTC by Leonid Kanter
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 12:10:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Kanter 2004-09-23 16:08:16 UTC
Description of problem:

I need to use my mobile phone as infrared modem, but in fc3test2
device /dev/ircomm0 is absent. I had to create this device manually.

Version-Release number of selected component (if applicable):

udev-030-26


How reproducible:

always

Steps to Reproduce:
1. connect usb-irda device (in my case - stir4200)
2. edit /etc/sysconfig/irda and start irda service
3. try to use infrared modem
  
Actual results:

/dev/ircomm0 - no such device

Expected results:

/dev/ircomm0 must be present

Additional info:

created device manually (mknod) - it works

Comment 1 Leonid Kanter 2004-09-23 16:10:16 UTC
sorry, entered wrong "assigned" and currently unable to change

Comment 2 Leonid Kanter 2004-09-23 16:37:37 UTC
right command is MAKEDEV ircomm0

Comment 3 Harald Hoyer 2004-09-24 07:51:56 UTC
hmm, or loading the module, should trigger udev, which creates this
device.

Comment 4 Harald Hoyer 2004-09-24 08:19:12 UTC
loading ircomm-tty, triggers the device creation..

Comment 5 Leonid Kanter 2004-09-24 08:39:55 UTC
Yes, but I don't like the idea of loading ircomm_tty manually. Before
udev it was always being loaded by kmod automagically when some
application (pppd, minicom, etc) try to open /dev/ircomm0. Now it's
impossible. Loading ircomm_tty manually is not user-friendly. Look
what we have now.
[root@leon root]# service irda start
ÐапÑÑкаеÑÑÑ IrDA:                                          [  ÐÐ  ]
[root@leon root]# lsmod | grep ircomm | wc -l
0
[root@leon root]# ls /dev/ircomm* | wc -l
ls: /dev/ircomm*: No such file or directory
0
[root@leon root]# cu -l /dev/ircomm0
cu: /dev/ircomm0: Line in use (it means - no device)
[root@leon root]# MAKEDEV ircomm1
[root@leon root]# cu -l /dev/ircomm1
Connected.
...
[root@leon root]# ls -l /dev/ircomm* | wc -l
32

If you create one device and try to open it - module is loaded and all
  other devices are created, but module must be loaded without user
interaction.

Comment 6 Eugene Kanter 2004-09-25 03:01:40 UTC
Same problem with SCSI scanner. I had to examine /etc/sysconfig/hwconf
SCANNER section and create device manually

class: SCANNER
bus: SCSI
detached: 0
device: sg1

# MAKEDEV sg1

Comment 7 Leonid Kanter 2004-09-25 21:53:04 UTC
The same for OSS emulation. Any application which use OSS will not
work out of the box until you run MAKEDEV dsp or load module manually.

Comment 8 Harald Hoyer 2004-09-27 08:05:16 UTC

*** This bug has been marked as a duplicate of 130746 ***

Comment 9 Harald Hoyer 2004-12-21 14:12:34 UTC
the irda initscript should modprobe ircomm-tty, if  /dev/ircomm* is used.

Comment 10 Karsten Hopp 2005-02-03 12:28:50 UTC
re: comment 9 
  It already does that. Did you by any chance happen to run one of those
  kernels without irda support ?
  What's the output of
    find /lib/modules/`uname -r`/kernel | grep ircom   ?

Comment 11 Leonid Kanter 2005-02-04 09:12:28 UTC
[leon@leon po]$ find /lib/modules/`uname -r`/ | grep ircomm
/lib/modules/2.6.10-1.741_FC3/build/include/config/ircomm
/lib/modules/2.6.10-1.741_FC3/build/include/config/ircomm/module.h
/lib/modules/2.6.10-1.741_FC3/build/include/net/irda/ircomm_core.h
/lib/modules/2.6.10-1.741_FC3/build/include/net/irda/ircomm_tty_attach.h
/lib/modules/2.6.10-1.741_FC3/build/include/net/irda/ircomm_event.h
/lib/modules/2.6.10-1.741_FC3/build/include/net/irda/ircomm_lmp.h
/lib/modules/2.6.10-1.741_FC3/build/include/net/irda/ircomm_param.h
/lib/modules/2.6.10-1.741_FC3/build/include/net/irda/ircomm_ttp.h
/lib/modules/2.6.10-1.741_FC3/build/include/net/irda/ircomm_tty.h
/lib/modules/2.6.10-1.741_FC3/build/net/irda/ircomm
/lib/modules/2.6.10-1.741_FC3/build/net/irda/ircomm/Makefile
/lib/modules/2.6.10-1.741_FC3/build/net/irda/ircomm/Kconfig
/lib/modules/2.6.10-1.741_FC3/kernel/net/irda/ircomm
/lib/modules/2.6.10-1.741_FC3/kernel/net/irda/ircomm/ircomm-tty.ko
/lib/modules/2.6.10-1.741_FC3/kernel/net/irda/ircomm/ircomm.ko
[leon@leon po]$ ls -l /dev/ircomm*
ls: /dev/ircomm*: No such file or directory
[leon@leon po]$ /sbin/service irda status
irattach (pid 4536) is running...
[leon@leon po]$ /sbin/lsmod | grep ir
ircomm                 14149  0
stir4200               13637  0
irda                  121469  2 ircomm,stir4200
crc_ccitt               2112  1 irda

ircomm was just inserted manually - no devices created :(

Comment 12 Karsten Hopp 2005-02-07 11:40:20 UTC
It's back to udev then, the device nodes should be created when the
ircomm module gets loaded

Comment 13 Leonid Kanter 2005-02-07 11:44:34 UTC
Device nodes are created when ircomm-tty module is loaded. It's better
to do it by "modprobe ircomm-tty" in /etc/rc.d/init.d/irda, see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133372#c8. Udev
is OK.

Comment 14 Karsten Hopp 2005-02-07 11:57:02 UTC
?? I'm confused now...

I don't care if loading ircomm (without -tty) doesn't create the
devices nodes as this won't happen if you use the initscript which
loads ircomm-tty first.
/etc/rc.d/init.d/irda already runs 'modprobe ircomm-tty', but comment
5 indicates that this didn't work. We need to find out why...
Please run the following as root and attach the output to this bugreport:
/etc/init.d/irda stop
sh -x /etc/init.d/irda start


Comment 15 Leonid Kanter 2005-02-07 12:10:12 UTC
Sorry, it happened somehow that I had outdated version of irda-utils
without "modprobe ircomm-tty". With irda-utils-0.9.16-3 it's ok.


Note You need to log in before you can comment on or make changes to this bug.