Bug 133375 - PyQt always segfaults on exit
Summary: PyQt always segfaults on exit
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: PyQt   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 133374
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-09-23 16:19 UTC by Bryan O'Sullivan
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 15:43:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qtest.py (300 bytes, text/plain)
2004-09-23 16:20 UTC, Bryan O'Sullivan
no flags Details

Description Bryan O'Sullivan 2004-09-23 16:19:46 UTC
Description of problem:

All programs written using PyQt segfault on exit.  This is caused by
the fact that PyQt is built using a deprecated version of sip that
does not support the current Python's threading API properly.  See bug
133374 for details.

This problem has existed since FC1, but is still present in FC3T2.

Version-Release number of selected component (if applicable):

PyQt-3.12-3

How reproducible:

100%

Steps to Reproduce:
1. Write a tiny PyQt program.
2. Run it.
3. Exit.  Crash!
  
Actual results:

Segfault.

Expected results:

Clean exit.

Comment 1 Bryan O'Sullivan 2004-09-23 16:20:58 UTC
Created attachment 104197 [details]
qtest.py

Simple test case.  Run "python qtest.py", then close the window and see a
crash.

Comment 2 Ngo Than 2004-09-24 15:43:11 UTC
i have update PyQt-3.13-1 and sip-4.1. both will show up in rawhide soon.


Note You need to log in before you can comment on or make changes to this bug.