Bug 1333793 - RPM claims ownership of files from the filesystem package
Summary: RPM claims ownership of files from the filesystem package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: lynis
Version: el6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Othman Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-06 12:30 UTC by Jeff Welch
Modified: 2016-06-05 06:48 UTC (History)
2 users (show)

Fixed In Version: lynis-2.2.0-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-05 06:48:19 UTC


Attachments (Terms of Use)

Description Jeff Welch 2016-05-06 12:30:47 UTC
Description of problem:

The Lynis RPM claims ownership of a number of files from the filesystem package.

Version-Release number of selected component (if applicable):

lynis-2.2.0-3

How reproducible:

Always

Steps to Reproduce:
1.rpm -qplv lynis-2.2.0-3.el6.noarch.rpm
2.
3.

Actual results:

drwxr-xr-x    2 root    root                        0 Mar 18 22:22 /etc
drwxr-xr-x    2 root    root                        0 Mar 18 22:22 /etc/lynis
-rw-r--r--    1 root    root                    13679 Mar 17 15:20 /etc/lynis/default.prf
-rw-r--r--    1 root    root                     1852 Sep 22  2014 /lynis
drwxr-xr-x    2 root    root                        0 Mar 18 22:22 /usr
drwxr-xr-x    2 root    root                        0 Mar 18 22:22 /usr/bin
-rwxr-xr-x    1 root    root                    41971 Mar 18 05:50 /usr/bin/lynis
...

Expected results:

drwxr-xr-x    2 root    root                        0 Mar 18 22:22 /etc/lynis
-rw-r--r--    1 root    root                    13679 Mar 17 15:20 /etc/lynis/default.prf
-rwxr-xr-x    1 root    root                    41971 Mar 18 05:50 /usr/bin/lynis
...

Additional info:

This seems to be related to the handling of %bashcompdir.

Comment 1 Othman Madjoudj 2016-05-08 00:12:40 UTC
I'll push an update to fix this issue in few.

Comment 2 Fedora Update System 2016-05-08 00:22:51 UTC
lynis-2.2.0-4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-66be3da17a

Comment 3 Fedora Update System 2016-05-08 21:18:33 UTC
lynis-2.2.0-4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-66be3da17a

Comment 4 Fedora Update System 2016-06-05 06:48:17 UTC
lynis-2.2.0-4.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.