Bug 133386 - tee does not support large files
tee does not support large files
Status: CLOSED DUPLICATE of bug 128390
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: sh-utils (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 13:37 EDT by Alexandre CUILLERIER
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre CUILLERIER 2004-09-23 13:37:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
/usr/bin/tee doesn't support large files (ie >2GB)
example:
$ cat /dev/zero |tee tmpt1.zero 
File size limit exceeded
$ls -lh tmpt1.zero
-rw-rw-r--    1 toto     toto         2.0G Sep 23 13:58 tmpt1.zero


Version-Release number of selected component (if applicable):
sh-utils-2.0.11-5.1

How reproducible:
Always

Steps to Reproduce:
1. use tee to generate a file
2.
3.
    

Additional info:
Comment 1 Tim Waugh 2004-09-24 03:39:03 EDT
This has the same root cause as bug #128390, which will be addressed
in a future update.

*** This bug has been marked as a duplicate of 128390 ***
Comment 2 Alexandre CUILLERIER 2004-09-24 05:40:39 EDT
Ok, thank you for replying.
I've applied the modification to sh-utils.spec
(removal of --disable-largefile on %configure line)

After recompilation, all seems to functions correctly now.
Thanks again.
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.