Bug 1333950 - Seeing rbd rename and rbd bench write crash when executed in parallel
Summary: Seeing rbd rename and rbd bench write crash when executed in parallel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-06 18:54 UTC by Tanay Ganguly
Modified: 2017-07-30 15:30 UTC (History)
4 users (show)

Fixed In Version: RHEL: ceph-10.2.1-1.el7cp Ubuntu: ceph_10.2.1-2redhat1xenial
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:37:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
renaming snap crash (6.38 KB, text/plain)
2016-05-06 18:54 UTC, Tanay Ganguly
no flags Details
rbd bench crash (835.28 KB, text/plain)
2016-05-06 18:56 UTC, Tanay Ganguly
no flags Details


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 15765 None None None 2016-05-06 19:16:27 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Tanay Ganguly 2016-05-06 18:54:44 UTC
Created attachment 1154727 [details]
renaming snap crash

Description of problem:
Seeing both rbd rename and rbd bench write crash when executed in parallel

Version-Release number of selected component (if applicable):
10.2.0-1

How reproducible:
Once

Steps to Reproduce:
1. Create an RBD Image.
rbd image 'testing2':
        size 102400 MB in 25600 objects
        order 22 (4096 kB objects)
        block_name_prefix: rbd_data.10af238e1f29
        format: 2
        features: layering, exclusive-lock, object-map, fast-diff, deep-flatten, journaling
        flags: 
        journal: 10af238e1f29
        mirroring state: disabled

2. Create 100 Snapshot.
3. Rename all snapshot
for i in {1..100}; do rbd snap rename None/testing2@snappy$i None/testing2@snap$i; done
4. rbd bench-write -p None --image testing2 --io-size 10240 --io-pattern rand


Run both step 3 and 4 in parallel.


Actual results:
Both starting execution, but after a while both "rbd snap rename" and "rbd bench-write" crashed (PFA)


Expected results:
There should not be any crash.

PFA, both logs (bench-write.log and renaming_snap.log)

Comment 1 Tanay Ganguly 2016-05-06 18:56:44 UTC
Created attachment 1154728 [details]
rbd bench crash

Comment 3 Jason Dillaman 2016-05-09 15:24:31 UTC
Upstream PR: https://github.com/ceph/ceph/pull/8999

Comment 4 Ken Dreyer (Red Hat) 2016-05-10 13:25:27 UTC
From Jason's email today:
> I have Jewel branch with all of these fixes (and a lot more) merged.
> I am running a test suite today.

Comment 5 Ken Dreyer (Red Hat) 2016-05-13 23:25:31 UTC
https://github.com/ceph/ceph/pull/9038 made it into v10.2.1 upstream.

Comment 8 Tanay Ganguly 2016-05-30 09:26:19 UTC
Marking it as Closed

Verified: 
ceph version 10.2.1-6.el7cp

Comment 10 errata-xmlrpc 2016-08-23 19:37:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.