Bug 133402 - Evolution can not print calendar views properly
Evolution can not print calendar views properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-23 15:24 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 16:58:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pdf output (68.42 KB, application/pdf)
2004-09-24 01:38 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2004-09-23 15:24:48 EDT
Description of problem:

Whenever I try to print a calendar view (monthly, weekly...) in
evolution the result is uter garbage: at least 80% of the characters
are replaced by empty rectangles in the printout (funnily enough some
parts of the page like days names do not seem to be affected)


Version-Release number of selected component (if applicable):

evolution-2.0.0-2

How reproducible:

always

Steps to Reproduce:
1. go into calendar view
2. populate the calendar wit ha few meetings
3. try to print the result
  
Actual results:

correct decorations, garbage text

Expected results:

readable page

Additional info:
I don't know if it ever worked since I never tried to print calendars
before the past month
Comment 1 Dave Malcolm 2004-09-23 17:25:21 EDT
Thanks for the report. I just tried this and it works for me, both in
Preview, and actual printing.

Does it work for you in Print Preview?  If it's reproducable there,
can you attach a screenshot?

Which views are you trying (e.g. Month View, Day View etc)?  
What versions of libgnomeprint and pango do you have installed?

Looking at the innards of the code (evolution/calendar/gui/print.c) it
uses "Sans Regular" for major "title" text in the calendar, and "Sans
Regular" for other text; perhaps one works and the other doesn't?
Comment 2 Dave Malcolm 2004-09-23 17:29:01 EDT
"Sans Bold" and "Sans Regular", I meant to say
Comment 3 Nicolas Mailhot 2004-09-24 01:37:58 EDT
Given Sans is a fontconfig alias we probably do not have the same one.
(here Sans=Vera mostly). I'll try to print a pdf file and attach it there.

Print preview is Fine & I test monthly view usually
Comment 4 Nicolas Mailhot 2004-09-24 01:38:43 EDT
Created attachment 104245 [details]
Pdf output
Comment 5 Nicolas Mailhot 2004-09-24 01:40:00 EDT
Ok here is a pdf. I'm afraid it's borked too but not in the same way
(when I print it the result is not the same). Here the problem seem to
be text orientation
Comment 6 Nicolas Mailhot 2004-09-24 01:43:23 EDT
I week view the pdf does not have the text orientation problem and
prints fine (except the margins are wrong). However if I choose to
print directly I get the same text corruption as usual. So it seems
the bug is limited to direct printing. (and text orientation in
monthly pdf is a different bug)
Comment 7 Dave Malcolm 2004-10-18 16:16:04 EDT
This works fine for me on a fresh install from Rawhide (20041014). 
Are you still able to reproduce this bug?  Is the machine on which
your seeing this running Rawhide, or FC2 with some package updated? 
What fonts do you have installed?
Comment 8 Nicolas Mailhot 2004-10-18 16:58:14 EDT
All the test run fine on today's rawhide - seem someone whacked the
bug while we were not looking.

Thanks for taking the time to look at it!

-> fixed rawhide

Note You need to log in before you can comment on or make changes to this bug.