Bug 1334021 - hostapd won't start
Summary: hostapd won't start
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 24
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-07 08:11 UTC by Göran Uddeborg
Modified: 2019-08-09 10:41 UTC (History)
1 user (show)

Fixed In Version:
Clone Of:
Environment:
Last Closed: 2017-08-08 14:25:25 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Göran Uddeborg 2016-05-07 08:11:19 UTC
Description of problem:
It seems bug 1266068 has returned in F24.  When I try to start hostapd (via systemctl) it fails with an SELinux alert (see below).  If I reenable the workaround I used in F23, it starts working again.


Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-184.fc24.noarch
hostapd-2.5-2.fc24.x86_64
kernel-4.5.2-301.fc24.x86_64


How reproducible:
Every time


Steps to Reproduce:
1. systemctl start hostapd


Actual results:
It fails to come up.


Expected results:
Running hostapd.


Additional info:
My workaround, which seems to solve the problem this time around too, is

allow hostapd_t hostapd_t:netlink_generic_socket
      { create setopt bind getattr read write };


The alert I saw before I activated the workaround looked like this

type=AVC msg=audit(1462607471.299:74923): avc:  denied  { create } for  pid=3299 comm="hostapd" scontext=system_u:system_r:hostapd_t:s0 tcontext=system_u:system_r:hostapd_t:s0 tclass=netlink_generic_socket permissive=0

Comment 1 Fedora End Of Life 2017-07-25 20:41:22 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 2 Fedora End Of Life 2017-08-08 14:25:25 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.