Bug 133413 - It is untolerably crippled
It is untolerably crippled
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-23 16:24 EDT by Jean Francois Martinez
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2004-09-23 16:24:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
System-config-packages has been around since RedHat 8.  That is about
two years.  And for two years I have been waiting for
system-config-packages having a button somewhere allowing to see ALL
the packages forming the distribution (instead of a third of them)
and allowing to add or remove support of a language (ie install all the
internationalized doc and fonts for that language and the components
you have).

On a multiCD distribution it is _not_ acceptable to have some two
thirds of the distribution not covered by package-installer and thus
forcing the user to deal with dependecies by hand.

Today this lack of basic functionality after two years is a bug and
that is why I am putting this on bugs to be fixed instead of in
Request for Enhancement.

An RFE would be the possibility of interfacing with third party
software (and solve their dependencies when they are about software
shipped in that release of RedHat/Fedora) or external repositories a
la urpmi/synaptic.

This is not about bells and whistles but about basic functionality we
need in order to be able to advocate use of RedHat/Fedora with a
straight face. 

Version-Release number of selected component (if applicable):
1.2.16

How reproducible:
Always

Steps to Reproduce:
1.  Fire the thing and look at all you can't do with it
2.
3.
    

Expected Results:  User should be able to see that "unimportant"
software in CD4 and he also should be able to remove everything
related to Chinese or Korean after he performed an "install everything"

Additional info:
Comment 1 Jeremy Katz 2005-09-21 15:51:06 EDT
Some of this exists in FC4 (language support groups).  Other parts will land as
part of the new tool being developed for FC5

Note You need to log in before you can comment on or make changes to this bug.