Bug 1334211 (CVE-2016-1541) - CVE-2016-1541 libarchive: zip_read_mac_metadata() heap-based buffer overflow
Summary: CVE-2016-1541 libarchive: zip_read_mac_metadata() heap-based buffer overflow
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2016-1541
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1334213 1334214 1335466 1353065 1353066
Blocks: 1334215
TreeView+ depends on / blocked
 
Reported: 2016-05-09 07:47 UTC by Andrej Nemec
Modified: 2019-09-29 13:49 UTC (History)
5 users (show)

Fixed In Version: libarchive 3.2.0
Doc Type: Bug Fix
Doc Text:
A vulnerability was found in libarchive. A specially crafted zip file can provide an incorrect compressed size, which may allow an attacker to place arbitrary code on the heap and execute it in the context of the application.
Clone Of:
Environment:
Last Closed: 2016-10-18 04:56:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2016:1844 normal SHIPPED_LIVE Important: libarchive security update 2016-09-13 00:11:35 UTC

Description Andrej Nemec 2016-05-09 07:47:12 UTC
A vulnerability was found in libarchive. A crafted zip file can provide an incorrect compressed size, which may allow an attacker to place arbitrary code on the heap and execute it in the context of the current user. The user must be coerced into unzipping the crafted zip file.

External references:

http://www.kb.cert.org/vuls/id/862384

Upstream fix:

https://github.com/libarchive/libarchive/commit/d0331e8e5b05b475f20b1f3101fe1ad772d7e7e7

Comment 1 Andrej Nemec 2016-05-09 07:47:45 UTC
Created libarchive tracking bugs for this issue:

Affects: fedora-all [bug 1334213]
Affects: epel-6 [bug 1334214]

Comment 2 Andrej Nemec 2016-05-12 09:33:08 UTC
Created libarchive tracking bugs for this issue:

Affects: epel-5 [bug 1335466]

Comment 3 Tomas Hoger 2016-05-17 17:47:10 UTC
Cisco Talos advisory for this issue:

http://www.talosintel.com/reports/TALOS-2016-0155/

Comment 4 Tomas Hoger 2016-05-17 17:50:27 UTC
Affected code was introduced via the following commit:

https://github.com/libarchive/libarchive/commit/1399a59680fa2dfca68764468ed0bcaa0331fde7

It was first included in version 3.1.0, therefore libarchive packages in Red Hat Enterprise Linux 6 and EPEL-5, based on older libarchive versions, are not affected.

Comment 9 errata-xmlrpc 2016-09-12 20:12:54 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2016:1844 https://rhn.redhat.com/errata/RHSA-2016-1844.html


Note You need to log in before you can comment on or make changes to this bug.