Bug 1334256 - [RFE] - Manage floating\shared disks with snapshots
Summary: [RFE] - Manage floating\shared disks with snapshots
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 3.6.5.1
Hardware: x86_64
OS: Linux
medium
high vote
Target Milestone: ---
: ---
Assignee: Ala Hino
QA Contact:
URL:
Whiteboard:
: 1056944 (view as bug list)
Depends On:
Blocks: 1113414 Gluster-HC-3
TreeView+ depends on / blocked
 
Reported: 2016-05-09 09:35 UTC by SATHEESARAN
Modified: 2018-05-27 13:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
RHEV-RHGS HCI
Last Closed: 2018-05-27 13:40:11 UTC
oVirt Team: Storage
ylavi: ovirt-future?
sasundar: planning_ack?
sasundar: devel_ack?
sasundar: testing_ack?


Attachments (Terms of Use)

Description SATHEESARAN 2016-05-09 09:35:34 UTC
Description of problem:
-----------------------
For RHEV-RHGS HCI disaster recovery, strategy recommended was to geo-replicate the data domain after snapshotting the VM disks, to the central site
(i.e) geo-replicate ( MASTER ) at Remote site to another gluster volume (SLAVE ) at the central site.

After importing the geo-replicated data domain at the central site, unable to list the unregistered disks.

The disks needs registering, in order to list the disks as the floating disks, and then it could be attached to the App VMs

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
RHGS 3.1.3 nightly ( glusterfs-3.7.9-3.el7rhgs )
RHEV 3.6.5
RHEL 7.2

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Create a data domain backed by gluster sharded replica 3 volume
2. Create VMs with their additional disks part of the above created data domain
3. Take snapshot of the VM's disk
4. Checkpoint the geo-rep session and start the geo-replication of data domain
5. After geo-replication reached checkpoint, stop geo-replication
[Note - step4 & step5 done via geo-rep scheduler script]
6. Import the slave data domain in another RHEVM instance
7. Try to list the unregistered disks

Actual results:
---------------
snapshotted disks are not listed

Expected results:
-----------------
snapshotted disks should be listed so as the help in registering the disks after fetching the disk id

Additional info:
----------------
I have deleted the the overlay image file from the data domain, leaving only the backing image. Now I could list the unregistered disks

Comment 1 Yaniv Kaul 2016-05-16 09:22:23 UTC
Any logs?
Tal - do we know what the issue is?

Comment 2 Allon Mureinik 2016-05-22 13:40:28 UTC
(In reply to Yaniv Kaul from comment #1)
> Tal - do we know what the issue is?
No logs - no analysis ;-)

Comment 3 Sahina Bose 2016-06-02 07:34:55 UTC
The issue is to do with listing unregistered disks in case disk has snapshots. Currently such disks are skipped. 
As per Maor, this is an RFE to manage floating disk with snapshots - changing title to reflect same.

Comment 4 Yaniv Lavi 2017-11-26 13:09:33 UTC
*** Bug 1056944 has been marked as a duplicate of this bug. ***

Comment 5 Doron Fediuck 2018-05-27 13:40:11 UTC
This was implemented in a different way for the HCI use case.
If relevant, please re-open and explain why.
As always- patches are welcomed!


Note You need to log in before you can comment on or make changes to this bug.