Bug 133430 - at-spi: accessibility is broken
Summary: at-spi: accessibility is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: at-spi (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-23 22:13 UTC by Zack Cerza
Modified: 2013-04-02 04:20 UTC (History)
2 users (show)

Fixed In Version: 1.6.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 10:20:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zack Cerza 2004-09-23 22:13:40 UTC
Description of problem:
After enabling accessibility, I see this error on startup of any GNOME
application:

"Accessibility: failed to find module 'libatk-bridge' which is needed
to make this application accessible"


Version-Release number of selected component (if applicable):
at-spi-1.5.3-1

How reproducible:
x86_64: Always
i386: Never

Steps to Reproduce:
1. $ gconftool-2 -t boolean -s /desktop/gnome/interface/accessibility true
2. $ gedit
  
Actual results:
Bonobo accessibility support initialized
GTK Accessibility Module initialized

(gedit:12637): Gnome-WARNING **: Accessibility: failed to find module
'libatk-bridge' which is needed to make this application accessible


Expected results:


Additional info:
$ file /usr/lib64/gtk-2.0/modules/libatk-bridge.*
/usr/lib64/gtk-2.0/modules/libatk-bridge.a:  current ar archive
/usr/lib64/gtk-2.0/modules/libatk-bridge.la: ASCII English text, with
very long lines
$ ar t /usr/lib64/gtk-2.0/modules/libatk-bridge.a
bridge.o

It looks like a libtool issue. Maybe a rebuild with a newer libtool
will suffice; maybe at-spi's libtool-fu itself needs an upgrade.

Comment 1 Mark McLoughlin 2004-09-24 10:20:16 UTC
Okay, I removed some redundant stuff from the spec file and we now
(magically!) the .so seems to pop out the other end correctly.

Fingers crossed :-)


Note You need to log in before you can comment on or make changes to this bug.