Bug 1334547 - [RFE][swift] Update container on fast-POST
Summary: [RFE][swift] Update container on fast-POST
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 10.0 (Newton)
Assignee: Pete Zaitcev
QA Contact: Mike Abrams
URL:
Whiteboard:
: 1257295 (view as bug list)
Depends On:
Blocks: 1378281
TreeView+ depends on / blocked
 
Reported: 2016-05-10 01:03 UTC by Sean Cohen
Modified: 2016-12-14 15:33 UTC (History)
8 users (show)

Fixed In Version: openstack-swift-2.7.0-2.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1378281 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:33:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 117710 None None None 2016-05-10 01:05:14 UTC
OpenStack gerrit 135380 None None None 2016-05-10 01:03:39 UTC

Description Sean Cohen 2016-05-10 01:03:40 UTC
Goal: enable fast-POST updates of content-type to be accurately reflected in container listings and be eventually consistent across object and container servers. 

Benefits: 
Allowing fast, efficient updates of metadata without needing to fully re-copy the contents of the object.

Comment 2 Pete Zaitcev 2016-07-30 00:13:54 UTC
Note that openstack-swift-2.7.0-2.el7ost is actually an OSP9 build.
We have further builds in OSP10.

Comment 4 Christian Schwede (cschwede) 2016-08-25 13:42:54 UTC
*** Bug 1257295 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2016-12-14 15:33:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.