Bug 1334604 - [RFE] add support for Ruby
Summary: [RFE] add support for Ruby
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: satyr
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matej Habrnal
QA Contact: Martin Kyral
URL:
Whiteboard:
Keywords: FutureFeature, Patch
: 1329607 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-10 07:10 UTC by Matej Habrnal
Modified: 2019-03-06 01:30 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 03:09:18 UTC


Attachments (Terms of Use)
Patch 1/2: Add support for Ruby report type (84.88 KB, patch)
2016-05-16 14:30 UTC, Matej Habrnal
no flags Details | Diff
Patch 2/2: python: add Ruby support (30.21 KB, patch)
2016-05-16 14:30 UTC, Matej Habrnal
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2307 normal SHIPPED_LIVE abrt, gnome-abrt, and libreport bug fix and enhancement update 2016-11-03 13:40:24 UTC
Red Hat Bugzilla 1418750 None None None Never

Internal Trackers: 1418750

Description Matej Habrnal 2016-05-10 07:10:58 UTC
Description of problem:
Support for Ruby is required by FAF server and without the feature doesn't work properly.
The feature lives in rhel7 upstream and was available in EPEL repository for a long time. Satyr was moved from EPEL to RHEL7 so we need the feature in here.

All is need is backport the two following patches:

https://github.com/abrt/satyr/commit/b0c2427cdc59be0bb1fa76e928b17d9aa1a0d4eb
https://github.com/abrt/satyr/commit/28db4ce2840d74f06b55c1e2c7c48f228708fb1d

Comment 1 Matej Habrnal 2016-05-16 14:14:25 UTC
*** Bug 1329607 has been marked as a duplicate of this bug. ***

Comment 2 Matej Habrnal 2016-05-16 14:30:43 UTC
Created attachment 1157960 [details]
Patch 1/2: Add support for Ruby report type

Comment 3 Matej Habrnal 2016-05-16 14:30:45 UTC
Created attachment 1157961 [details]
Patch 2/2: python: add Ruby support

Comment 7 errata-xmlrpc 2016-11-04 03:09:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2307.html


Note You need to log in before you can comment on or make changes to this bug.